[SOLVED] No "Device" properties other than libinput for Mice

Solution: Never install libinput and xf86-input-libinput.

The Wikis assume the mouse properties by default contain "Device" properties, however I do not get any other than libinput.

"Device" properties as in those that go for "Device Accel Profile" etc.

I've done a recent fresh install off from a LiveUSB, the hop between xorg-server 1.16 and 17 somewhat removed the basic drivers that loaded by default, as well as how there's no xorg.conf in /etc/X11.

I've tried:

# Xorg :0 -configure

just to get:

Section "ServerLayout"
	Identifier     "X.org Configured"
	Screen      0  "Screen0" 0 0
	InputDevice    "Mouse0" "CorePointer"
	InputDevice    "Keyboard0" "CoreKeyboard"
Section "Files"
	ModulePath   "/usr/lib/xorg/modules"
	FontPath     "/usr/share/fonts/misc/"
	FontPath     "/usr/share/fonts/TTF/"
	FontPath     "/usr/share/fonts/OTF/"
	FontPath     "/usr/share/fonts/Type1/"
	FontPath     "/usr/share/fonts/100dpi/"
	FontPath     "/usr/share/fonts/75dpi/"
Section "Module"
	Load  "glx"
Section "InputDevice"
	Identifier  "Keyboard0"
	Driver      "kbd"
Section "InputDevice"
	Identifier  "Mouse0"
	Driver      "mouse"
	Option	    "Protocol" "auto"
	Option	    "Device" "/dev/input/mice"
	Option	    "ZAxisMapping" "4 5 6 7"
Section "Monitor"
	Identifier   "Monitor0"
	VendorName   "Monitor Vendor"
	ModelName    "Monitor Model"
Section "Device"
        ### Available Driver options are:-
        ### Values: <i>: integer, <f>: float, <bool>: "True"/"False",
        ### <string>: "String", <freq>: "<f> Hz/kHz/MHz",
        ### <percent>: "<f>%"
        ### [arg]: arg optional
        #Option     "Accel"              	# [<bool>]
        #Option     "SWcursor"           	# [<bool>]
        #Option     "EnablePageFlip"     	# [<bool>]
        #Option     "ColorTiling"        	# [<bool>]
        #Option     "ColorTiling2D"      	# [<bool>]
        #Option     "RenderAccel"        	# [<bool>]
        #Option     "SubPixelOrder"      	# [<str>]
        #Option     "AccelMethod"        	# <str>
        #Option     "EXAVSync"           	# [<bool>]
        #Option     "EXAPixmaps"         	# [<bool>]
        #Option     "ZaphodHeads"        	# <str>
        #Option     "EnablePageFlip"     	# [<bool>]
        #Option     "SwapbuffersWait"    	# [<bool>]
	Identifier  "Card0"
	Driver      "radeon"
	BusID       "PCI:1:0:0"
Section "Screen"
	Identifier "Screen0"
	Device     "Card0"
	Monitor    "Monitor0"
	SubSection "Display"
		Viewport   0 0
		Depth     1
	SubSection "Display"
		Viewport   0 0
		Depth     4
	SubSection "Display"
		Viewport   0 0
		Depth     8
	SubSection "Display"
		Viewport   0 0
		Depth     15
	SubSection "Display"
		Viewport   0 0
		Depth     16
	SubSection "Display"
		Viewport   0 0
		Depth     24

With it not being recognized if I manually change "mouse" to "evdev".

A little backstory to it was that I wanted to start anew and not bother with UEFI or EFI booting with my SSD. I also cannot register movements when they're small enough, even if I move my hand on that threshold.

This is what the mouse xinput displays:

(9 goes for Razer Orochi, seems to be detecting it as a keyboard as well now.)

$ xinput list-props 9
Device 'Razer  Razer Orochi 2013':
	Device Enabled (138):	1
	Coordinate Transformation Matrix (140):	1.000000, 0.000000, 0.000000, 0.000000, 1.000000, 0.000000, 0.000000, 0.000000, 1.000000
	libinput Accel Speed (292):	0.000000
	libinput Natural Scrolling Enabled (293):	0
	libinput Send Events Modes Available (256):	1, 0
	libinput Send Events Mode Enabled (257):	0, 0
	libinput Left Handed Enabled (294):	0
	libinput Scroll Methods Available (295):	0, 0, 1
	libinput Scroll Method Enabled (296):	0, 0, 0
	libinput Button Scrolling Button (297):	0
	Device Node (258):	"/dev/input/event0"
	Device Product ID (259):	5426, 57

What I'm trying to achieve is either loading the previous driver that had a LOT more properties, or just adjust to the mouse driver to be as precise as the older one. Like I said, I can move my mouse without it registering it.

I've also tried adjusting acceleration via xset, as well as the threshold for it, no success either.

"What do?"

After reading this I'm still not sure what your problem is.

The library I was using was the generic Xorg instead of evdev. uninstalling xf86-input-libinput and libinput fixed it, since it was inaccurate as hell.