[Solved] Nexus 7 Failing to boot

My Brothers gen 1 Nexus 7 is failing to boot, it just brings up the funky moving colored balls and sits there fore eternity. I have tried completely draining the battery and the restore feature in the boot loader neither of which have worked. Any suggestions?

Unfortunately he has owned the thing over a year so no warranty anymore. They won't take it back

So I fixed it... kinda

I spent along time googling and came to the conclusion that I would be able to install a new rom if USB debugging was enabled, however it wasn't and the tablet wouldn't boot up so that sucked. Back to google and went through a whole bunch of forums which eventually lead me to download the Nexus 7 Android Toolkit and then I used that to unlock the boot loader. I then followed the instructions to install stock Android which it didn't do, but it did kick the device back into working order (having rest itself to factory settings).

So its fixed, not sure for how long but it works at the moment.