[SOLVED]New motherboard, windows can't find usb devices

Hello guys,

I got my inheritance money, and bought some new hardware. My move of my Linux os was fine, with the unfortunate result of my 1tb drive dying. But that’s not my problem.

Windows boots up, seems to be ready for me to log in, but my keyboard doesn’t work, nor does my mouse. I think Windows doesn’t have any drivers for my usb ports. Is there a way to fix this? I’ve tried booting into safe mode, and the results are similar.

Am I doomed to just re-install my windows, or is there a way to resolve this ? Thanks in advance for any ideas.

Got any USB to PS/2 adaprtos around. That should not require drivers and you can get around with a keyboard for as long as it takes to get the drivers you need.

1 Like

I booted the raw disk in a VM and installed the drivers with pnputil in command prompt. You may be able to boot to command prompt or use a usb2 PCI card…

I guess I’m ordering a usb2ps/2 adaptor. I threw out my last one a couple months ago lol. forgot about those ports! And new motherboard has one!

Does your keyboard work in the bios/uefi. If so do you have an option to turn on usb legacy support in the bios. That may fix it.


Yeah they can be handy to have around. I have a bucket of various wires and bits that are rarely used but I know once I throw them out that in will need them.

@JayCeeEhm, yes my mouse and keyboard do. I’ll check that out too.

1 Like

Does the windows version being windows 7?
And does your new motherboard only have usb 3.x ports?
Then yes you need to install drivers firstly before those usb 3.x ports will work.
Because windows 7 by default does not support usb3.

If its windows 10 then it basically should work.
Hower sometimes you need to login firstly before it re-installs all the drivers.

Only solution being usb to ps2 adapter, and use the driver cd or download the latest drivers in case of windows 7.

1 Like

Is there anyway to insert the drivers into Win 7’s driver pool while I’m in LInux? Or is that a specific thing that has to be done by windows itself?

And no, the usb 2 ports aren’t even detected. Which is weird asf.

I know for XP there was slipstreaming drivers onto the ISO so it would detect other things during install. Not sure if this can be done injecting from Linux but try looking in that direction.

I dont really think that it would be possible in an existing installation.
Like @Zibob did mention, it is possible to slipstream usb3.0 drivers into an existing iso.
The only way i see it, would be to use a ps2 keyboard to get acces to windows.
Then install the usb drivers from the driver cd.

But which motherboard did you get?

Also since you changed your motherboard, your windows activation will also fail.
Unless you have an retail license.

Getting windows 7 installed on newer platforms,
with motherboards that down have any usb 2.0 ports.
Is kinda a pain in the ass.

I got this motherboard:

And windows seems to work perfectly fine. I was an insider for 7 and have a lifetime licence for it, so I think that will work fine. Either way, that windows 7 never sees the internet. I have all networking devices turned off for it. I don’t have any games that need internet connection.

I hope I can just make an ISO of the cdrom, or download the usb drivers for this motherboard, put them on a usb stick and then install them that way, once I get my usb to ps2 adapter.

I fixed this! I got the ps/2 adaptor, and went onto the mb manufacturer’s website and downloaded their usb injection tool. was gonna just reinstall windows.

Then I thought about it. Opened the folders of the tool, and the drivers were actually in there. So I went to device manager and just directed it to where those drivers were, and boom. USB 3.0 and 3.1 worked! So happy!

There are other things on the mb that don’t have drivers, and I should probably re-install windows. But I’m satisfied that everything works fine and I can install games I can’t run in Linux. So I’m good. If there comes a problem with it, I’ll update this thread!

Thanks guys!

1 Like

You can download all the drivers and software suite you need from Asrock’s website.