Return to Level1Techs.com

[SOLVED] Need help troubleshooting - POST passed but no boot

helpdesk

#1

I need some help troubleshooting a no boot issue I am running into on a SuperMicro X8STi-F motherboard. Posted here since I ended up with “Enterprise” motherboard.

Little backstory

I did have a flawlessly running machine up till a year ago where Windows would hang and need a restart. System was a Asus Sabertooth X58 board, i7-950, and 24 GB RAM. Once I hard reset the machine, it would post but fail to boot, do another hard reset and then will boot.

I had the thought that the motherboard was going bad (had the system for 6 years or so) but dealt with the restarts. I finally got a replacement and went with a SuperMicro since it was a cheaper option than replacement consumer X58 boards.

After setting up the X8STi-F

After getting the board switched out, I don’t think that was the problem, cause I get the same result. I am testing with a known good usb stick with Ubuntu installer. So no disks (had cheap-o SSDs in before)

Thought the RAM might be suspect and swapped to a known good 4GB module. Same deal. Only thing still the same in the other machine is the CPU. Now my mind is stuck on that and I didn’t need to buy a new motherboard.

Would a system POST with a bad CPU? Doesn’t make sense. Anyone have thoughts or experienced the same thing?


#2

no they wil not run post if the cpu is bad you will just get a blank screen and the power supply will run.
bad or incorrect memory can present itself in post with a series of low beeps and video card failure would be a higher pitch tone but that not always the case with different manufacturers.
did you get any error codes listed from your drive (for example 1176 was a drive controller failure in hp computers for a long time)?
unless there is a latent or legacy usb feature in the bios the usb ports are not activated until the post has completed sensing the hdds.
I would suspect the ssd drive has failed to detect and bios is hanging up there.
test using a known good sata or ide drive ( i keep some with peppermint linux on them and hardware doesn’t matter to it as much as windows.
If the system boots to the os there is nothing wrong with the mainboard or memory.

otherwise look carefully for possible shorting to the case.


#3

No error codes when I was first not getting the machine to boot. Currently I have no drives plugged in except for the usb drive. A 16gb lexor usb 2.0 stick. Shows up in the bios and set it as first to boot. Enabled legacy usb as well.

I suspected that a machine won’t post if the CPU was bad. So I will have to try different image for my boot media. I was doing a Ubuntu 16.04 server installer image, could I be running into incompatibility with EUFI?


#4

yes eufi setting will not let an unauthorized os to boot in the system.
microsith included a code on their installation media as a security measure for that hardware.
changing from eufi to legacy or ide modes(if there) will allow the system to boot a linux distro.

earlier dell systems used a similar method for their hardware except they used a coded initialized hdd. if you wanted to upgrade your hdd you had to buy it directly from them (and i might add at an over inflated price)


#5

Looking it up, the X8STi doesn’t support UEFI. So that isn’t the issue.

I will have to keep try various things to see if I can get it boot.


#6

poses an interesting problem there
the only other thing i can think of at the moment is that the cpu may have some damaged cache ram on it.
depending on its location the cpu would basically function but not up to full capabilities and may be hanging up when the function calls for the use of the damaged section of the cache.
If it was the ssd that was bad it should have booted up to the usb providing the iso was functional.


#7

Solved…

IT WAS THE FRIGGIN GRAPHICS CARD!

Since the SuperMicro board had VGA, I switched to that and bam! I was booting to an OS.

I also dropped the CPU back into my X58 board and it boots fine as well. Just dropped a different card I borrowed in there since I don’t have on-board video.

In the end I ended up with an extra pc for CHEAP since used X5600s and X8 series MB are sub $50 on eBay.