[Solved] Mellanox ConnectX2 Driver Issues?

I picked up a pair of ConnectX2 Cards for some 10G networking but am having issues with drivers on my desktop side. I’m running Fedora 29 on my Desktop and Debian/Proxmox on the server side. I haven’t been able to exactly pin down what causes as basic internet trafic is fine but an NFS share can cause it as well as Iperf3 tests will cause the mlx4_en driver to start spitting out the following in dmesg repeatedly:

[ 312.660522] mlx4_en: enp7s0: DMA mapping error
[ 312.660966] mlx4_en: enp7s0: CQE error - vendor syndrome: 0x71 syndrome: 0x2
[ 312.664252] mlx4_en: enp7s0: CQE error - vendor syndrome: 0xf9 syndrome: 0x5

I have swapped the SFP+ addapters on both sides and also swapped the cards with the same results only on the Fedora system

Fedora Kernel 29 4.19.13-300 - mlx4_en Version 4.0-0
Debian Kernel 4.15.18-9-pve - mlx4_en Version 4.0-0

both Cards FW 2.9.1200 (Had also tried FW 2.10.0720)

Turns out it was because I had the card in an unused x4 slot. Moved it to a PCI-E x8 and now I have no issues.

1 Like

edit your title to solved