(SOLVED) Maybe a motherboard issues

my PC is having a really bad hard lockup with no bsod randomly thru out the day and i did over clock my north bridge and forgot about but it but i put it back to stock speeds and i may have a malfunctioning north bridge so im curious can the north bridge cause system lockups with out bsod

Everything is stock now ?

Hmm id say you hurt your northbridge a bit. See if you can disable all the automatic features. Can I get the model name and specs of your build. It sounds likely to be a power issue.

1 Like


Unless you increased the voltage as part of the overclock it is doubtful the northbridge is damaged. If you did increase the voltages then it could be a damaged voltage regulator or DMA controller.

What make and model are these items:
BIOS ver:


Any USB devices plugged in all the time? I had a bad hub causing Windows 8.1 Pro to crash on a brand new computer. Once the hub was removed the problems went away.

Cpu FX8350
Motherboard Asrock fatality 990fx killer bios version 1.50
Ram gskill sniper series 16gb 4x4 gb
Psu rosewell lighting 1000w
Os windows 10 home 64bit

I thought about the usbs also and still froze up i even stole my wifes ram oyt of her pc and still froze up and i i no its good ram

I dont recall uping the voltages just the nb from 2200 to 2800


I would suspect the motherboard at this point. It can cause lockups and shutdown failures even when everything passes the tests. Same thing happened with 2 Sabertooth motherboards for me. Both from the same production lot.

I hope you get it figured out soon.

i just got my new laptop hdd to test my desktop with and used acronis to copy my ssd to the hdd which was very successful i might say didnt think it would work but it did but i got immediate results from the new drive. i checked the event logs to see when the last time it froze up and what do i see File System Filter 'npsvctrig' (10.0, ‎2015‎-‎10‎-‎29T21:40:23.000000000Z) has successfully loaded and registered with Filter Manager. right after start up and no system freeze up idk if this is to early in my test but i think my ssd is trashed which every test i ran on it says its heathy but im going to leave my desktop on for atleast a week with out restarting unless i have that will be a full out test of the new drive

But i spook to soon it locked up on me over night with the new drive with the same file system filter so now im testing it with windows 8 then upgrade 8.1 from windows 10 to see if the issues tranfers from os to os on another drive if so my mobo is bad but if it doesnt then i would suspect the ssd has failed unless im wrong with that therey

update new hdd with window 8.1 still locks up with out bsod

update replacing cpu with fx4300 froze up over night im aiming for a defecive motherboard now

disable C1E and C6 states in the bios, and see if that changes anything.

Ahhh I've seen this issue before.. The sabertooth boards and and asrock boards have a week south bridge so everything locks up and freezes right after post or some random time after that. In fact their first few. Batches were pretty spotty on whether you'd get a good controller. It was something to do with the onboard asmedia failing which sent the controller crashing ... I'd send in for a new motherboard. Easily fixed.

hmm well the asrock 990fx killer is a expenive board im trying to figure if i should wait and deal with the freezing or get a cheap board and get the board i have now later on

Nope return RMA for a new one. its not the board or ASrocks fault.. AMD made a weak SB man

i have had the board since 2/27/2015 so im not eligable to do a rma for it i kinda figured lol

then wait.. get an interim board and upgrade in the future to intel

ya i agree that intel has taken the market over amd but i still like amd b/c there cheap and they do the job :D

what interim board you recommend that is cheap for the fx4300

who do you exchange the FX8350 for a FX4300?
that makes no sense realy

my wife is using my fx8350 while i tested the fx4300 from her pc to mine

Ah okay makes sense, thanks for explaining.
I think that you might just have some bios issues, do you have your bios updates to the latest stable version?

yes maam 1.50