[Solved] Manjaro XFCE - black screen with cursor, "cannot open display"

So I was ricing my Manjaro XFCE install on my Dell XPS 15.
I installed some themes, icons packs and did some custimization to compiz.
Now all was fine and well, till I accidentally applied a conflicting enable of two features on compiz. The window manager stopped working, I couldn't focus any other windows then the terminal and my keybinding weren't working, so I rebooted.
Well now when I log-in to XFCE4 it just shows me a black screen with my cursor. I can open a terminal via ctrl+alt+F2 and have wifi in there.
I tried lot's of different things, but I keep getting the same error from different applications. They all spit out in some form or the other "Cannot open display" with nothing else. This includes xfwm4 --replace, xrandr and compiz --replace.
I have reinstalled both the free and non-free hybrid drivers and tried uninstalling compiz but I can't seem to find how to remove it because pacman says it ain't installed.

EDIT AND SOLVED: The reason I couldn't find the package was because I installed compiz-manjaro, not compiz...
I removed it, purged the config files, reinstalled. And wow it work's again. That was quite stupid...
With this thread to the depth's of the noob helpdesk!!!


It good to here you figured it out