[Solved] ISCSI share Steam games do not launch with Proton

I have a Freenas setup with a single iscsi share that I want to use to share my library between Windows and Linux (Manjaro) dual boot. Running games from the NAS on Windows has worked without issue for every game I have tried. However in Linux only native Linux games will launch from the share, even games I know work with Proton on this system do not launch when moved to the share.

Has anyone tried a similar setup and gotten games to work with Proton?

Doesn’t work AFAIK. It’s either, or. I tried to so something similar a few years ago and that was a known limitation at the time. This might’ve changed since then.

Edit: I think I found something that might help you.

Due to the nature of NTFS, creating files/folders with characters Windows cannot read will cause disk errors (leading to games that don’t launch), the most common issue is a ; character in filenames that Proton creates on the NTFS disk.

1 Like

That did the trick, thank you.

1 Like