Return to Level1Techs.com

[SOLVED]Installing discord on Fedora

I’m going to play around with it some more tomorrow, but thought I would pose the question in case anyone else has already done the legwork:

I’m trying to install discord on Fedora and can’t seem to either obtain the tar.gz from discord, or they don’t have one. I also tried using alien to convert the deb to rpm, but there seem to be quite a few missing dependencies. As a side note, I’m familiar with Debian distros, but super-noob to Red Hat distros. Any thoughts or advice for things to try?

You can get the tar.gz for discord from this page:

1 Like

I can’t, actually. It only gives me a deb. :confused:

Interesting that it doesn’t list it. The direct download link is this: https://discordapp.com/api/download?platform=linux&format=tar.gz

1 Like

I tried this also, and still got the deb. Do you get a tar.gz? If so, do you mind reuploading somewhere I could download?

Strange, I get the tgz as normal. Might be some weirdness with your browser and could always try wget

wget -O discord.tar.gz https://discordapp.com/api/download?platform=linux&format=tar.gz

Edit: Looks like discord messed up the download, this should work:

https://mega.nz/#!z5lxFbYK!e8_rLRxxTMpxhiEnCKH7CoCT115LXFcV9Cm2iBlqxpo

1 Like

I had it working a while back- best I can say is that the version I had installed was Discord Canary. I tried to find it with a quick search to no avail.

I used the software app and it installed fine called “Discord Canary”. Discord seems to update itself when launched after that. I rarely use it however.

The source listed software for it was;
copr-be.cloud.fedoraproject.org

1 Like

You need to select the tar.gz from the drop-down first

These’s a flatpak for discord

http://flatpak.org/apps.html

3 Likes

When I click that link it provides the .tar.gz as expected.

Discord messed up the download for that specific time period where it only provided the .deb package even if you downloaded the .tar.gz but kept the filename the same, If you uncompressed the tarball you’d find the deb package file structure. it fixed its self soon after that.

ahhh ok

Under Ubuntu 17.10, Discord on two separate occasions using 2 different versions of discord had my mic turned on without me knowing it. People could hear what I was doing and I had no idea until someone told me.

Imagine the things you say and do in front of your computer when you think nobody can see or hear you. :confused:

Yeah, I’ll not be reinstalling discord for a while, if ever.

Not really relevant to the thread. Also it’s on you to mute your mic if your sitting in voice.

Personal anecdotes aside, would be nice if OP updates with the current status of his issue.

Sorry. Having different issues, but still haven’t gotten it fully functional yet. @MichaelLindman was right about the tar.gz giving me the deb anyway, but that’s resolved now. (Discord’s site works again as well, so now I look like a crazy person…)

Unfortunately, now that I’ve installed it using the tar.gz, I’m getting the same issues a lot of people had about a year ago on the windows version. That is, I only get a gray (blank) window, and nothing else.

On another hand, I tried an alternate method on Windows 2012r2 (The only other OS I’m running simultaneously), and it works, but discord thinks the install is corrupt, after doing a fresh install with multiple downloads of the install media. Lol I can’t win.

Edit: As a side note, I have a lot going on during the workweek, so I only get about 2-3 hrs of playing/fixing/eating before I need to sleep again for work. Sorry if the delays in between are too long. :confused:

That blank screen issue is caused because Discord requires libcxx, you can install it with:

sudo dnf install libcxx

and it should work afterwards.

2 Likes

Will try that tomorrow. I suspected it might be a missing dependency, but I hadn’t looked at what I was missing yet. Thanks for the feedback!

2 Likes

I wasn’t in voice. Problems with Discord are relevant to the thread.