[Solved] I messed with xorg.conf and now everything is slightly broken

So I was looking for a way to disable Vsync. Because I don't know what I'm doing, I ran these commands.

And now when I boot, I get a splash screen with the words "Linux Mint 17.1" and four animated dots. I can still go to TTY1 and get to the desktop normally with startx though. Also my audio stopped working, and the only output device listed is "dummy output".

Deleting the xorg.conf didn't work, and I also noticed that the conf created by nvidia-xconfig gets emptied by rebooting.

eh happens to everyone at some point. Just remove xorg, and nvidia drivers the sane way. Then reinstall the opensource drivers and xserver-xorg drivers. Also run sudo apt-get install -f

So first

sudo apt-get remove xserver-xorg
sudo apt-get purge nvidia*

and then

sudo apt-get install xserver-xorg
dpkg-reconfigure xserver-xorg
sudo apt-get install nvidia-current
sudo apt-get install -f

I need to make sure I'm not making things worse.

edit: forgot to reply to the post, so here's a mention: @LinuxMaster9

edit2: well, that didn't work.

Don't immediately reinstall your Nvidia drivers!!!!! I said OpenSource drivers NOT proprietary drivers. aka the Noveuo(sp?) drivers. just purge the Nvidia drivers and purge xserver-xorg. Then install xserver-xorg and when you get the desktop, then try reinstalling the nvidia drivers.

I noticed that the MDM Display Manager failed during the boot (I could see the text behind the splash screen by pressing any arrow key), so I googled around a bit and ran these:

sudo update-rc.d -f mdm remove
sudo update-rc.d mdm defaults

Now everything is fixed.