Return to Level1Techs.com

[Solved] How MSI Afterburner does it in windows?

Hi,

I have nvidia p104-100. TPU is locked in windows. GPU clocks and vram clocks is locked in linux but TPU is not.

I am wondering why is that MSI Afterburner can overclock and underclock gpu and vram? Is there any workaround for a bios locks with nvidia?

1 Like

What do you mean by “TPU” ?

Have you tried nvidia-smi

1 Like

Actually I ment TPD but still I used term wrong. What I really ment was power limit.

I applied next settings:

sudo nvidia-xconfig -a --allow-empty-initial-configuration --cool-bits=31 --use-display-device=“DFP-0” --connected-monitor="DFP-0"

Result:

Section "Monitor"
Identifier     "Monitor0"
VendorName     "Unknown"
ModelName      "Unknown"
Option         "DPMS"
EndSection

Section "Device"
Identifier     "Device0"
Driver         "nvidia"
VendorName     "NVIDIA Corporation"
BoardName      "P104-100"
EndSection

Section "Screen"
Identifier     "Screen0"
Device         "Device0"
Monitor        "Monitor0"
DefaultDepth    24
Option         "AllowEmptyInitialConfiguration" "True"
Option         "UseDisplayDevice" "DFP-0"
Option         "Coolbits" "31"
SubSection     "Display"
    Depth       24
EndSubSection
EndSection

nvidia-smi do not show xorg running on the GPU.

sudo nvidia-smi -q -d SUPPORTED_CLOCKS

==============NVSMI LOG==============

Timestamp                                 : Wed Jun  9 09:49:19 2021
Driver Version                            : 460.73.01
CUDA Version                              : 11.2

Attached GPUs                             : 1
GPU 00000000:04:00.0
    Supported Clocks                      : N/A

You can try this on Nvidia-smi on windows, I have a feeling Nvidia not being Linux friendly is a part of why it’s not showing up

https://cryptomining-blog.com/tag/nvidia-tdp-limit-nvidia-power-limit/

Are you using the card for compute, gaming, or mining?

You can increase the power limits of an Nvidia GPU in software, and not require hardware mods (ex. Shunt mod)? Would this work on a 1060?

If someone struggling with same issue here is the solution with intel igpu:

What I used: Debian 11, nvidia-driver 460.73.01-1, GNOME Shell 3.38.4

Create /etc/X11/xorg.conf.d/10-nvidia-drm-outputclass.conf

Section "OutputClass"
    Identifier "intel"
    MatchDriver "i915"
    Driver "modesetting"
EndSection

Section "OutputClass"
    Identifier "nvidia"
    MatchDriver "nvidia-drm"
    Driver "nvidia"
    Option "Coolbits" "31"
    Option "AllowEmptyInitialConfiguration"
    Option "PrimaryGPU" "yes"
    ModulePath "/usr/lib/nvidia/xorg"
    ModulePath "/usr/lib/xorg/modules"
EndSection

Remove /etc/X11/xorg.conf

Install package primus

Now I can achieve full range power limit, gpu clock and memory clock settings.

Took a look at this link, and with a bit of digging, it appears that Nvidia-SMI is in-fact installed with the Studio Driver (not sure about the non-studio driver) for the GTX 1060. Typing “nvidia-smi” in the cmd prompt shows that it’s there.

Using the nvidia-smi cmd nvidia-smi -i 0 -pl 175 , it told me what the max allowable power limit for the GPU is (140W) and that the bios of the card was programmed to 120W.

Free performance! This also allows a user to easily bring down the power of a GPU if they so desire. Very cool. Just have to remember to set the power limit (pl) at every restart.