[solved] Gnome Tweak tool driving me nuts!


I have this strange problem with Gnome tweak tool where the extensions tab is not there.


I don't know why the hell its not there and I have tried sudo apt-geting gnome-tweak-tool about a bilion times and updating and ... I just don't know.


All I want to do is enable shell extensions!

What OS?

Ubuntu 14.4

your logged in the gnome session?
Also make sure both gnome-tweak-tool and gnome-shell-extensions-user-theme are installed

  1. Yes. I believe so. Although I don't really know what that means... or how to check that.

  2. okei gnome-tweak-tool is definitely installed. However gnome-shell-extensions-user-theme gets an error

"E: Unable to locate package gnome-shell-extensions-user-theme"

Also for some reason I need to "sudo su" to install these... idk

I don't have much experience with linux but aren't the extensions* managed through Firefox? Logan used it in his "Logan's Linux Log" video -> open Firefox, enter http://extensions.gnome.org
Not sure if this helps.

edit: *for gnome

you get them from here https://extensions.gnome.org

And yes you have to use firefox to get them.

However shell extensions seem not to be enabled at all on my system. You have to enable them in tweak tools to be able to install them from firefox.

I am unable to do that because the "Shell extension" tab that is supposed to be in tweak tools is missing.
and I don't know how to fix that /:

Have you tried this -> https://askubuntu.com/questions/71181/gnome-tweak-tool-does-not-show-extensions

It's for older versions of Ubuntu (11.10 and 13.04) but it might be worth a try. The second answer (login page) seems to be the easiest solution that needs no tinkering (if it works at all).

edit: Also this one:

After installing the user theme extension, you should restart
gnome-shell. Only then would the extension show up in the GNOME tweak

To do that, press Alt + F2 and enter r in the dialog box. Now gnome-shell would restart and the extension will show up in the tweak tool.

Source: https://askubuntu.com/questions/75604/why-does-users-theme-extension-not-show-up-under-gnome-tweak-tool

Botom one did not work.

and I have no idea what the top one wants me to do?
it seems to be a directory... That I can't find...

Sorry I could not help. I'm not really familiar with linux :(

1 Like

eeey. its ok(: Im just hoping that someone has run into this before

Couldn't you "just" uninstall Gnome and re-install it?

It seems to be common on Ubuntu. It shouldn't happen. Not sure what to suggest. Looks like Ubuntu doesnt package all the usual packages.

Id maybe consider updating to a newer version of Ubuntu and see if that works, the version of gnome shipped in 14.04 is pretty ancient.

really? /: and there is now way of doing that without a fresh install...

See if the Metadata.json file is showing the right GNOME-Shell Version you're on.

Go into Bash and type

then type

Use Nano or Gedit whatever text editor you prefer (I use Gedit here) and see if the metadata.json file states the current GNOME version you're on if not make sure it says the version you're on then log out or reboot. it should fix it

Also forgot to mention if you don't already know how to check what GNOME version you're on, go into BASH and type

No such file or directory error

and i am running GNOME Shell 3.10.4

See if this works. go into the BASH again,

then try

OKEI :D that opened the file metadata.json

It says I am running 3.10

Do I change it to 3.10.4 ?

yes sir. then reboot.

See if it fixes your problem.

Nope. still no extensions tab in tweak tools.


But now if I sudo gedit metadata.json
it opens ... but is blank?