[SOLVED] Gnome GUI Glitch

Heya tek folks!

I've been using linux for quite a few years (mint mate & cinammon, ubuntu, elementary) but never gnome. I'm rocking 16.04 LTS. At first glance, the GUI looks great and I intend to use it as my daily driver for development (I'll keep my casual gaming on the windows desktop for now). However I came across a cursor glitch. The arrow seems to be ghosting when interacting with certain elements: the search input, the Activities button and there might be some corner cases for the menu.

I can't printscreen the bug since when I trigger the printscreen action( native or with shutter app ), the GUI wipes clean and then it saves the jpeg.

My laptop is old. I got an i7 2630QM (Sandy bridge) and the integrated graphics on this iteration of CPU isn't great, however the nVidia GT 540M should cover it. I thought my problem is driver related, but on either integrated or dedicated graphics, the bug still occurs.

Has anyone else encountered this bug and maybe found a solution to it?
I'll try out some theme tweaking tools like compiz and see if I can get rid of it. I'd rather not though, this glitch seems OS related.


Is gnome-tweak-tools installed? You can try setting it on a different theme. Maybe that fixes it, else you have to hope next update of gnome that there is a fix or report it yourself (unless you want to really go deep and search the issue yourself).

Something related to a window manager or desktop environment is usually never OS related. Anyways, try gnome-tweak-tools and mess around with different themes, that might fix it.

That not normal on default gnome installs. I've certainly never seen it.

What version of gnome is it?
Does it do the same in Wayland? (Not sure if Ubuntu has Wayland support)

Hmm good one, they can use wayland but still a buggy version but i think you need to do afford for it and its not something you do on accident like in Fedora (but i can be wrong on that). Only Sail OS, Fedora Rawhide use and Fedora 25 it as default.

Yeah it's an option at logon on fedora 24, default in 25. It does fix a lot of xorg issues which is why it might be worth seeing if it's reproducible in Wayland

Yeah, i wonder if he indeed installed Wayland by accident and forgot about, because its a weird issue to read.

I would go to 14.04, then wait for 17.04

I'm using ubuntu gnome 16.04 LTS.
Since I can't actually printscreen ... I went oldschool and took a photo with my phone rofl( open the image in a new tab for a larger preview ).

I'm not sure what wayland is in ubuntu or how could it help me here.
As for gnome-tweak-tool... in progress. I'll return with my findings.

can you log out and in the inlog screen there should be a button if you want to use Gnome. can you switch that? or at least tell what options you got.

I have the following options: Cairo-Dock(GNOME), System default, GNOME, GNOME Classic.

PS: Gnome-tweak-tool didn't do the trick, even without animations and the simplest UI the bug still occurs. Stepping up to unity-tweak-tool.

oh nvm you say in gnome classic its also?

I had to reboot and relog in order to get the actual classic theme and... big suprise: the bug is still here. :)

EDIT: @kungr Why would you go from 14.04 to 17.04? Do you have some info regarding the in between versions?

Hmm am not a Ubuntu user usually (in fedora you don't need to restart).
But open a terminal and run journalctl -f or/and dmesg -w and hope somthing pops up that makes sense.

Not sure but it can be best to run these commands as root but think you will see the error nonroot too.

I got the following output from journalctl -f :

Cairo.Surface is leaking, programmer is missing a call to Dispose
Set MONO_CAIRO_DEBUG_DISPOSE to track allocation traces
Cairo.Surface is leaking, programmer is missing a call to Dispose
Set MONO_CAIRO_DEBUG_DISPOSE to track allocation traces
Cairo.Surface is leaking, programmer is missing a call to Dispose
Set MONO_CAIRO_DEBUG_DISPOSE to track allocation traces
(gnome-shell:3971): mutter-CRITICAL **: meta_window_raise: assertion '!window->override_redirect' failed
(gnome-shell:3971): mutter-CRITICAL **: meta_window_lower: assertion '!window->override_redirect' failed
Removed session 1.
Removed session 2.

EDIT: I must say, I wasn't expecting any leaks from a fresh LTS install :D

I accidentally solved the issue...
1. I switched to nvidia binary driver (proprietary, tested) which resulted in black screen on the next restart
2. rebooted in safe mode
3. unmounted the system partitions: mount -o remount,rw /
4. removing the nvidia drivers: sudo apt-get remove --purge nvidia-*
5. two reboots (on the first reboot the OS alerted a graphic driver issue, on the second it reinstalled the driver i guess)

EDIT: I guess something glitched somewhere.


I've just found that 14.04 is a rock solid release in general and I think that 17.04 will be the next one (that is when 14.04 support ends?).

I've put newer versions on scratch machines but my rock solid desktop is 14.04.5 (Just Released). IMO

Still think its a weird issue., but good that its solved. I never really ran much Nvidia open source stuff. Know from the passed that they are not good. Lucky Nvidia is a little bit more serious in developing some sort of better driver. In the passed the opensource Nivida drivers were terrible but surprisingly better then what Nvidia programmed.

Ah dunno why we didn't ask about drivers earlier. Open nvidia drivers in Ubuntu will be crap, its just to far behind. Newer versions are alright but still bit of work to do. Are you using propriatory or open drivers then? Sounds like you are now.

The legacy drivers for nVidia were always behind, but I reckon they still were ahead of AMD's driver solutions for linux.

Speaking of nvidia driver pains, a while back you had to install another 3rd party software to benefit from the integrated and dedicated graphics( bumblebee, which was an open source optimus equivalent for linux ) with the downside that the switch between the two was done manually.
e.g.: optirun glxspheres for running with the dedicated card

...and you guessed it, sometimes there were incompatibilities between bumblebee and the nVidia driver (even though the driver was ok by itself).

So you missed out on all the fun. :)

The nVidia drivers were installed in first instance. And my OS crashed by switching from nouveau driver to proprietary drivers( apparently it's a know issue: https://bugs.launchpad.net/ubuntu-gnome/+bug/1559576 ). Now I'm back on nouveau, but without the occuring bug.