[SOLVED] Games being forced to secondary monitor

So I have an amd gpu and duel monitors. The secondary monitor is to the left and games always launch on this monitor. I am not sure how to force it to primary display. Moving the window to primary doesn’t even work. I even set my secondary monitor as primary and the game launches on the window I want it to so it seems to force it to secondary every time.

Let me know about any details you need such as drivers, config files etc.

1 Like

How about distro and DE as a start? :wink:

1 Like

Fedora and Gnome :slight_smile:


Every time I have this issue I set the game to windowed mode, then I move the game to the correct window then set it back to full screen. It seems to do the trick.

1 Like

I wonder if this isnt a strict Gnome problem. Because I believe this also happens to KDE users too.

Unless I’m thinking of another issue with programs going to another screen.

I had that a couple times on KDE, yeah. But @jdfthetech solution is exactly how I “fixed” that: just drag it over and go back to full screen.

1 Like

I’ve tried this but it doesn’t work however switching the secondary monitor off when launching the game works. I guess I can work with this but it may get tedious after a while.

I fixed this issue with launch options in dota but I’m guessing the parameters are different for every game.

I’ve had it as well.

If you go to display settings and select single display click apply and when the confirm box comes up press revert settings and the game should launch on your main display after that.


I’ll try this tomorrow and post back.

could you let us know what driver you’re running? I know that the issue you describe is a constant problem on my old GTX 970 PC running NVidia drivers, but that my new Ryzen system running a Vega hasn’t had this problem.

So I’m thinking maybe it has something to do with NVidia. Can anyone confirm my theory? Has anyone seen this issue when running a radeon card?

I’m using an amd card (mesa drivers off the top of my head), I’d be sceptical of the DE’s in Linux causing this problem

This did the trick, thank you!


very weird trick, I’ll have to remember this


Way to go bro!


Added solved text into title

1 Like

Unfortunately this doesn’t persist on reboot :frowning:

simple solution . . .don’t reboot!

1 Like



Shall I take the [solved] text out then OP?

Possibly. I’m not having the issue anymore. Some games keep working and some do not. War for the overworld is a bad offender but I dont recall the feral game ports doing it anymore.

Some games seems to remember displays they were launched on last and some do not.

The developers should really be told about it. I was talking to the WftO dev’s but when I switched to Fedora they basically said only Ubuntu is supported.

I mean how many gamers are linux. How many are dual display. I just settled for the 15 second fix on fedora of right click, single display, revert settings. The actual games are not looking for the correct primary display. Be that a wayland thing or xorg etc. I dont know.

if you are using steam a fix i used a while ago was when ever i launched a game i set it to launch big picture mode which you can select which monitor to launch games on and when game closes so does big picture

1 Like