Return to Level1Techs.com

[Solved] Freenas SMB access from Windows 10 Edu

freenas

#1

So I put together a freenas system together in a dell t30. Nothing special just 4x2tb drives to play around with and get use to the system. I have installed the OS, made a pool and a data set, enabled SMB on said data set, configured my network devises, default gateway and nameserver, and checked that SMB in active. I can see the system on my windows system and can ping it with no problems, how ever I can not get access to the drive. when trying to open the system i get “windows cannont access \freenas” error. I also tried mapping the drive using the Map network drive utility and still have had no luck. Any thoughts or suggestions would be very appreciated.

Update: Got alittle further with Map Network Drive, I now get “you can’t access this shared folder because your organization’s security policies block unauthenticaed guest access”. If its helpful I am using a copy of win 10 edu 64bit.

Thanks,
HF


#2

This sounds like an issue on the Windows side. Are you by chance running this system on a windows network with active directory? Im am completely unfamiliar with Win10 edu, but this sounds like a group policy or active directory issue. Sorry I dont have more information. Someone that is more familiar with this will chime in i’m sure.

I ran FREENAS for a few years on a home server, once everything is working, it is really nice.

If no one else finds the answer for you, I will dig around after work and see if I can find something more substantial.

EDIT: @Hadesfriend remove “solved” from the thread title. People are going to see this and assume the issue has been resolved. You will draw more attention this way.


#3

In addition to removing the “solved”, you might want to also consider making the title otherwise more descriptive. “X problems” doesn’t really describe anything.

I’d suggest “Freenas SMB access from Win 10 edu”. A “problem” at the end would be largely redundant and would only work to make the title unnecessarily long.


I agree that it’s most likely a policy problem. Are you working in an organization or do you have complete control of the Windows system?


#4

In policy editor, toggle:

Computer configuration\administrative templates\network\Lanman Workstation\Enable insecure guest logons


#5

@Hadesfriend I updated your thread title with something more meaningful. Also, please update your thread with the solution to your problem. Thanks.


#6

I’m just being nosey, but what did you move onto if you did? Perhaps you just had less need for it or went more cloudy?


#7

I thought win10 needed both the host and shared folder, I.E:
\\Freenas\totallynotpron\ rather than just \\Freenas\


#8

That limitation actually comes from SMBv2 and v3. Only SMBv1 supports browsing.


#9

I did that because I did solve it before anyone answered. Thats why i didn’t respond to anyone, i wasnt expecting anyone to respond after i did that. It ended up being an issue with my switch.


#10

I moved over to Ubuntu 16.04. It allowed me to roll ywo of my servers into one, and give me more options for futurrle expansion.


#11

Very good, glad you got it fixed.


#12

thats what i get for using a switch pulled from a dumpster


#13

Thanks for letting me know :+1: