[SOLVED] Dell R710 iDRAC 6 not working


i have a Dell R710 with iDRAC 6 enterprise management adapter, though I think I configured it correctly it won't work;

Am I mistaken, but it actually should give a gui over https?

The only ports I can find open when scanning the iDRACs ip are 22, 5900 no port 80 or 443 are open.

When I try to connect to ssh i get this response ssh_dispatch_run_fatal: Connection to no matching MAC found and connecting to 5900 with vncviewer will time out.
I also tried to connect to port 22, and 5900 with firefox just in case the webserver might listen there.

By now I am running out of ideas; I tried to map the iDRAC to its dedicated nic or the system nics, but the result is the same no mater what.

By now I am out of ideas and hope any of you can help me, maybe @wendell or @DeusQain have time to help me?

Yes it should.

Take a look at this as well.


1 Like

I'll tell you right now install windows 08 r2 or 2012 or 2012r2 and use that to update the life cycle controller and drac fw. They are different things bit depend on each other. Update the bios first from a Rufus freedos USB stick. I had to do this the other day it was awful.

1 Like

Thank you Gentleman! - I will try your suggestions and report back how it went!

Yeah its a pain; that was the first thing I did when I got it... and since than I fight with the idrac ;)

EDIT1: downloading 2012r2 is the worst experience ever... at least from Microsoft; it's like proposing my first born to the devil. facepalm

EDIT2: I am totally amazed how painfull this server is to update. I do not wonder why the former owners never did any! any firmware upgrade.. not the bios not the PERCi/6 nor the iDRAC 6 got any love after the macine was bought.

Huge thank you @wendell and @DeusQain!

It was a hideous experience but it works! I am amazed how bad the system is to maintain O.o
Dell for sure does not get a prize for usability when it comes to their software packages; I had to reset the iDRAC(server) a whooping 9 times until the update finally worked.
It keept complaining about Failed to access Virtual USB Device despite the iDRAC was already reset during bootup ^^

Long story short, thank you @wendell for directly sending me the windows 2012r2 route; I likely would never have thought of that helping!

no prob. I might had to do this on this exact model a time or 150.

the Drac isn't really too bad.. you can update it via the web but you have to keep up with the updates over time. Dell doesn't plan for people to have an easy time updating their server if they neglect it for years then suddenly update it.

there are redhat linux update options as well but those have been less than bulletproof.

The drac itselfe is realy good, I get to like it! - I guess, what I did "wrong" is that I updated the bios, as that was all that I changed and the seller (my companies IT dept) swears it was working 4 days ago XD

I am glad that I could profit from your suffering. ;)