[Solved] Can't install distros on SSD (SYSLINUX)

Hello.

In retrospect it wasn't very wise to tinker with a running system but I had to try out other distros. But after installing Ubuntu 14.04 on my netbook's SSD I can't install any distro at all, even after formating it.

The SSD is formated in ext3 with a 1012.34mb big part of unallocated space (showing up as "extended" in Gparted).

When I try to boot with a USB installer (doesn't matter if Mint 17, Lubuntu 15.04 or Ubuntu 14.04) I only get this message on the screen.

When I power up with only the SSD plugged in I get this message on the screen

Can anyone help me figure this out? (looked it up on the web, only got more confused since I suck at dealing with Linux)

EDIT: I'm not sure anymore of this the cause of the problem is Linux/SSD related. Just swapped the SSD out with my old 2.5" HDD and I get the same SYSLINUX message when a bootable USB flash drive is plugged in. When I power it up without a flash drive plugged in I get this message

Update: The problem only occurs when I insert a USB flash drive with a live version of a Linux distro (Lubuntu, Mint, Ubuntu). When I create one with Windows 8 on it it works fine.

in the grub rescue

fdisk -l

let us know what it tells you

What software are you using to mount the iso file on the usb drive?

Nothing, because both the SSD and HDD are blank (there's nothing on them). I only get the BIOS text when I put a USB flash drive with a live version of any Ubuntu based Linux distro in.

I have no idea what caused this problem but when I power the netbook up with a Windows or Fedora installer USB flash drive it works. Only Ubuntu based distros seem to cause it.

Not really solved, but since I can install Fedora again it's fine with me.

Universal USB Installer v1.9.5.4

This post was flagged by the community and is temporarily hidden.

You deleted your entire system by accident. A reinstall is your only option.

@Dynamic_Gravity I couldn't do that with Lubuntu, Ubuntu or Mint (-> "Missing parameter in configuration file"). I got stuck there and couldn't do anything than shut it down. Fedora and Windows were the only two OS that would let me past a BIOS post.

@QwarkDreams use the tools that @mumblevagabond recoomended

  1. make a gparted bootable usb or cd
  2. reformat your drives
  3. install the os

use Rufus or Win32diskimager to burn mount the iso and check the md5 hash when you are done.

I already used Gparted and reformated both my SSD and 2.5" HDD. I'm still not able to install any Ubuntu based OS.

How do I check the md5 hash/what should I watch out for?

the tool does it automatically, and check which partition scheme you need for the os you want to install.

there is a check box on both programs I recommended to do so. if the has is bad one re-download load the image

Rufus doesn't have a checkbox for that (at least the portable version doesn't) but I'm using Image USB now.

@Taco_Bell @mumblevagabond @Dynamic_Gravity Thanks for the help, guys!
It looks like Universal USB Installer messed up (although it's funny that it only effected Ubuntu-based distros; Fedora and Windows worked fine).

Used Image USB yesterday for Lubuntu 15.04 but was too tired to try it out. Plugged the USB flash drive in a few minutes ago and Lubuntu installs just fine.

Also, thanks for the patience. I know I'm quite slow when it comes to Linux (guess my brain's kinda stubborn after ~17 years of using Windows).

you're fine man, glad everything worked out.