[SOLVED] Can't access hard drive - really important that I can get my data back from it

Didn't work. :/

Okay, another update here. Seems like theres a new block of "Linux Swap" on the hard drive, fuck my life for taking the easy way and letting the partitions get chosen automagically.

HOWEVER, while I cannot access the drive itself, I can copy files 1 by 1 through testdrive.
that means that I have now regained my critical documents, the only shitty thing now is to find something to back all of it up to and then reformat the hard drive.

Is your motherboard SATA controller set in RAID mode for some reason?

It appears to me ubuntu is seeing your old Data hdd as a raid member disk. But that isn't necessarily a problem, you can mount a broken mirrored raid in Linux and recover all your data (but not a broken striped RAID for fairly obvious reasons).

I would be able to fix this for you very quick if I could get my hands on the system, but it is somewhat harder through a forum.

Here are some instructions for accessing an LDM member disk from an external site. Please mount it as read only of you attempt this method!

Here are the steps to follow:

1. Install ldmtool. On Debian and Ubuntu systems, type apt-get install ldmtool. It should be similarly easy on most other recent Linux distributions.
2. Run ldmtool create all.
3. You should now have a bunch of new entries in /dev/mapper. Locate the right one (in my case, a RAID1 array, so /dev/mapper/ldm_vol_VOLNAMEHERE-Dg0_Volume2), and just mount it with something like mount -t ntfs /dev/mapper/ldm_vol_VOLNAMEHERE-Dg0_Volume2.

the controller isn't set in RAID mode;
this is my output from ldmtool:

ldmtool create all

idk if this is working at all.

I am able to access my data right now through test disk, I do have to copy it over though. So if I could mount the drive and everything working again, that would be stellar

You didn't' accidentally install an OS on the storage drive correct? If not, I'm sure all your data is there. Lets take your Ubuntu distro out the equation and download, burn this:


Boot into that disk and lets see if your drive shows up.

Well, though it isn't extremely helpful, the fact that ldmtool returned nothing suggests that your drive is not in fact an LDM disk. I am assuming you have tried simply mounting /dev/sdb3 as NTFS?

HelloMrOwl's suggestion is honestly a very good idea, I have had... odd experiences... with Ubuntu and mounting different Windows formatted drives. If you have a disk sitting around that you could use, it would be a much better way to try and get the drive mounted. However, you will then also need another harddrive to mount and copy the data onto from your old drive. You could use the current ssd with Xubuntu on it, but I think you should avoid using that disk for the time being if you go this route.

i tried mounting it, didnt wanna work.

Right now I'm copying the essentials over to the ssd and the rest will go onto an external hard drive (doing it via testdrive). That way I don't have to reboot into anything. It's just kinda a mess to copy a terabyte of data :x

That sounds fairly tedious.

Can you post the error message it provides when you attempt to mount it as NTFS? I have to head to work now, but I will try to keep glancing here throughout the day.

Or, if your patience is formidable, I suppose you can just stick to testdrive.

My recommendation would be to backup all data and format everything. Format your storage drive. Format your SSD, and reinstall the OS.

Does your drive show up under the places drop down in linux?

Yes master!

I gotta be more careful next time, literally rage quitting windows and installing Linux couldn't go well.

I'm just happy I can get my files back, even if it's a crapton of work. I guess that's the punishment.

Just don't do automatic partitioning if you actually care about partitioning. If you're lucky you only nuked metadata and all of your files could be fine. Anyway, do not use the system you installed because if it actually gets mounted and used it can overwrite your data.

@Zedd you had it correct when you mentioned ldmtools. the partition wont mount normally because its using logical volume management stuff. Unfortunatly the answer was always going to be the partition is not worth struggling with, back it up and recreate without using ldm and without using ntfs if you dont need windows access.

Im assuming you got access to the data from the look of your post, butfor some informaitn heres a bit of reading. https://stackoverflow.com/questions/8427372/windows-spanned-disks-ldm-restoration-with-linux

Someone else had similar problems on the forums but using ldmtool on its own didn't seem to work. what was your solution?

Also feel free to mark this topic as solved for others :)

My solution was to install testdisk and copying stuff from the drive to an external one manually through it.


program might seem a bit confusing for someone who hasn't worked with terminal before, but once you get used to it it's a pretty easy procedure.

  • choose the drive you have troubles with
  • analyse
  • there will be a partition which seems to contain your data (for me it was sdb3 with 981 GiB), choose that one and press P
  • now you can select files with : (shift .) and then C (shift c) to copy them over to a new location
  • navigate to your location and then press c again
  • data is getting copied over.

I hope someone will find this helpful in the future. :)

Thank you to all of you kind people who helped me out in such a short amount of time.


I have my Volume1 in /dev/mapper. When I try your command with my drive name, I get β€œcan’t find in /etc/fstab.” I tried some google-fu to fix THAT error but am having no luck. Any further advice? Thanks.

@HeatR216 hey, welcome to L1T. This thread has been inactive for four years. Please create a new thread with your issue.