[SOLVED] Analogue Sound Output Disappeared

Running Ubuntu Gnome 14.04 and a Xonar D2X

It was all running fine until I was looking at the sound options and clicked on the Sound Profile, which was blank. Then the analogue output just disappeared from the selectable outputs and now I have no sound.

I have tried flushing alsa followed by a reboot to no avail, if that is even relevant to my situation, as that was a common suggestion during my Google searches.

Could you tell me if you can find your audio card in /proc/asound/ ?
What is the output of

cat /proc/asound/cards


cat /proc/asound/devices

0 [NVidia ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xfb080000 irq 36
1 [NVidia_1 ]: HDA-Intel - HDA NVidia
HDA NVidia at 0xf9080000 irq 44
2 [D2X ]: AV200 - Xonar D2X
Asus Virtuoso 200 at 0xd000, irq 26


1: : sequencer
2: [ 0] : control
3: [ 0- 3]: digital audio playback
4: [ 0- 7]: digital audio playback
5: [ 0- 8]: digital audio playback
6: [ 0- 9]: digital audio playback
7: [ 0- 0]: hardware dependent
8: [ 1] : control
9: [ 1- 3]: digital audio playback
10: [ 1- 7]: digital audio playback
11: [ 1- 8]: digital audio playback
12: [ 1- 9]: digital audio playback
13: [ 1- 0]: hardware dependent
14: [ 2] : control
15: [ 2- 0]: digital audio playback
16: [ 2- 0]: digital audio capture
17: [ 2- 1]: digital audio playback
18: [ 2- 1]: digital audio capture
19: [ 2- 0]: raw midi
33: : timer

Well, either I'm interpreting these values wrong or the kernel doesn't even see an analogue ouput.
You said that it was working fine before clicking something in the sound options.
Can you confirm the card is working (e.g. under Windows).
Did you do any recent updates?

I'll boot into Windows to double check but it was working fine shortly before

The only updates I may have done prior to this problem showing was to get some missing libs for Steam

Yes working fine in Windows still

Could you also post the output of cat /proc/asound/modules ?

0 snd_virtuoso
1 snd_hda_intel
2 snd_hda_intel

The correct module for your sound card is loaded.
Install alsa-utils and check alsamixer (in the command line) to see if the outputs are there.

I've had similar issues with pulseaudio before, and it generally causes a lot of headaches for me. Try reinstalling pulseaudio using these instructions: http://askubuntu.com/a/475665 . Works occasionally for me.

sudo apt-get install alsa-utils
Reading package lists... Done
Building dependency tree
Reading state information... Done
alsa-utils is already the newest version.
alsa-utils set to manually installed.
The following packages were automatically installed and are no longer required:
linux-headers-generic-lts-utopic linux-image-generic-lts-utopic
Use 'apt-get autoremove' to remove them.
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

Not sure how to do the second thing you said

Just open up a terminal and type in alsamixer - hit enter.

Doesn't look like it's there

I'm kinda running out of options here.
You should try and disable /mute (press space) the S/PDIF channel.
Also, you could go through some of the ALSA basics:

OK thanks for your help anyway

Tried muting the S/PDIF but it wouldn't work on any of the output channels. Tried it on the inputs and it did :S

Is it working again?

No, I meant I couldn't mute the outputs but I could mute the inputs

Interesting development

I made another user account and it all works fine in that account.

Is there some way to solve this without having to just create a new user account?

Check if you can find the ~/.pulse/ and ~/.config/pulse/ directories and rename them (e.g. pulse-old) - you could also just delete them, however renaming them is the secure way.

I have had similar problems. In short, it's PulseAudio's fault and there are two simple ways to try to deal with it. The one I recommend trying first is

(sudo) apt-get install pavucontrol

...which will give you a slightly less stupid audio source/mixer control than the one that comes with Gnome by default, and will hopefully allow you access to your analog inputs and outputs from any user account.

If that doesn't work, uninstall everything related to PulseAudio, especially pulseaudio-module-x11 which, at startup, takes command of all audio sources and then fails to manage them intelligently, as you've discovered. The reason I recommend this only if the first approach fails is that pulseaudio is that other programs may depend on pulse. God only knows why so many developers have chosen to access the audio subsystem via pulse rather than ALSA, but they have.

1 Like