Return to Level1Techs.com

[SOLVED] 2990WX getting RAM up to speed, need a bit of help

helpdesk

#1

Hello! I just built a monster workstation with the wonderful 2990WX. Everything went smoothly on the hardware side, I’m just having issues getting my RAM to run at its speed of 3200Mhz. Here are the parts:

Threadripper 2990WX 3GHz
Custom loop with 360 rad
MSI - MEG X399 CREATION EATX TR4 Motherboard
G.Skill - Trident Z RGB 32GB (4 x 8GB) DDR4-3200 Memory
Intel - 760p Series 256GB M.2-2280 Solid State Drive
Seagate - Barracuda 3TB 3.5" 7200RPM
Radeon R9 290X Windforce
SeaSonic - PRIME Platinum 1000W 80+ Platinum

I have installed the latest bios, I have tried using ryzen master and the XMP in bios however it just won’t boot! In fact, when I change the RAM speed and exit bios or ryzen master, it doesn’t restart, just sits there glowing rainbow. I’m not really into overclocking or anything too technical, I’m an artist and not overly savvy with these things, I just want everything to run as it says on the box. Currently CPU-Z is reporting that I’m running 32Gb 1066Mhz at 15-15-15-36. My RAM is rated for 3200Mhz at 14-14-14-34. Is it going to require some tinkering to get it up there? or is there something simple I’m missing? any help would be appreciated. Thanks!


#2

I would rotate the dimms meaning you move all the dims to one the left and take the left most and put it on the right to start.

You are using the outer slots right? E.g

XoXoCPUoXoX

Right?
Where o is empty slot and x is filled slot?

1066 is usually massive fallback. Is this possibly an ancient kit? Paste the screenshots of cpu-z memory tabs?


#3

Yes rotating worked, thanks wendell! Im kicking myself