So my LG G6 just died, what didn't i try yet?

The LG G6 that i gave to my mom just died, and i have no idea what to do next.

To give some context, the phone froze when charging. The always on clock was still updating, but impossible to unlock it and the phone/sms wouldn’t work.

Long press power button did nothing (over a minute) so i tried power + vol down for a hard reset

It DID turn off … and that was it.
Nothing since. no charging animation, no powering up …
After 24H without news, i decided to open it up and unplug the battery…
Not easy but i managed to not break much, unpluged the battery and waited a bit.

battery unpluged, and phone pluged, nothing more, can’t start it. while plugged in it draw about 0.05a at 5v

if i reconnect the battery, it doesn’t change anything, but the device draw 1.32A at 5V

no usb device on linux.

So … do you have any idea i didn’t think about ? i don’t have anything like a jtag.

Aside from data lost because she insisted on not using the nextcloud note app, and was bothered by the duplicate warning on the picture sync, i really want to bring it back to life if possible because she won’t accept anything that big, let along bigger, if i have to buy a new one …

I had a g5 (memory is not good, it may have been a different android phone ) that started acting very wierd. Eventually replacing the battery solved the problem.


I’m with alwaysFlOoReD on this. Try to get a new battery in it and see what happens. I highly doubt there has been a catastrophic failure of the charging circuit and those symptoms look very much like a battery that has given up.
Since the battery is also that old and not working I’d make sure to “store” it outside in a metal box or something so that, if a runaway happens, nothing will catch fire in your mom’s house.

1 Like

shouldn’t the device just … boot when powered on with the cable ?
Or show me a red flashing batteries if it isn’t connected ?
I know my G4 used to do that…

1 Like

They don’t. The battery is in series with the USB connector. As far as I know only a couple gaming phones have the ability to cut the power to the battery to avoid overcharging and overheating while gaming. All the other phones are battery devices first.

Can’t quote on the “error message” it should show, it varies wildly depending on the Android version alone.

I’m starting to think there might be more to it. Since the device is pulling power it can’t be the battery, why did I say that!? Charging ICs are pretty smart and if the battery was on it’s way out it wouldn’t accept any kind of current.
Since the device was on and you only managed to turn it off I’m starting to sense a NAND failure of some kind. What was running when it was on were the last data the NAND and RAM could retain. Once power was off everything cleared and nothing works anymore.

What I don’t get is why you’re not even seeing something like a static LED that shows the device getting powered? There must be something like that for these catastrophic events or if the battery gets too low. I’m not sure if it does have an LED like that, but that would help make sense of this situation.

1 Like

Did you measure the voltage of the battery itself? They have a Battery Management System (BMS) built in to the cell that will shut off when low to keep the cell from discharging too deeply. The BMS will turn back on if you apply voltage to it from either a charger or another cell. Usually just tapping the wires on the appropriate pads is enough to turn it back on to be ready to accept a charge. I’m right in the middle of salvaging over a dozen 36V 18650 cells and even when under 1 volt I can usually get them back to life with the majority of its rated power capacity.

Given that this was ‘charging’ at the time it went unresponsive, I would double check and make certain that the charger is working on another device as well as the charging circuit on the device itself where it connects to the battery. It seems like no power was reaching the battery and the BMS shut down for safety.

If the cell currently reads 0 volts even after reassembly and trying to charge with a different charger, then power isn’t reaching the cell which is most likely a power connector issue.

1 Like

I’ll try to see if i can prob the battery with a voltmeter, but the bms was working normally to my eyes since it pulled over 1a for a bit then slowly went down to 0.8, 0.7, and now it idle at 0.5.
So I think the battery is now full.

They should from memory be a red led when charging power down, and a display with a battery on it.
But nothing, no screen, no led, no vibration…
Also holding the power button dont make it draw more power shortly, so no failed boot sequence.

Sounds like it’s time to take it out back and put a .22 to the cpu!!!