So I think I broke it... [solved]

I just flashed a new motherboard bios today (updated from version 1.2 to 1.8) on my MSI Z87-G43 motherboard. It went without a hitch and everything seemed stable. Of course after the update I had to redo my overclock since none of my profiles carried over, but this was fine because I had all my settings on paper anyway. So I did some stability tests and during a stress test my PC shutdown, and restarted saying the overclock settings failed.

All settings were reset to default values.

The previous overclock settings have failed, system has been restored to its default settings.

Press F1 to run setup.

Press F2 to load default values and run setup.

Normally I can press F1 to jump into my bios, but now it freezes at this screen. Pressing F1 or F2 does nothing. my bios dead? Is my motherboard borked? What do I do?

If it makes any difference the rest of my rig is listed on my profile.

I've never bricked a motherboard, but from what I've heard if you can see something, it isn't fried. If you can boot into windows, try updating again, maybe?


It won't boot past this screen. I took the mobo battery out and put it back it, and still stuck at this screen. If I could get anywhere past this point I would be good to go. For some reason I think it is freezing up at this step.

cmos clear

thank you. That fixed it.