Return to Level1Techs.com

SMB share slower than expected


#21

Which options are those? And do you mean the config in /etc/local/smb4.conf?


#22

Oh I thought you added smb.conf options through the GUI ?


#23

I did, but I only added a few options when I tried improving the performance. Those are these:

socket options = TCP_NODELAY IPTOS_LOWDELAY SO_RCVBUF=65536 SO_SNDBUF=65536
max xmit = 65535

Everything else is default like it ships. Technically I can remove them again, since it makes no difference for my performance.


#24

Maybe try it? Then reboot everything ?


#25

Done, but still the same situation. Same (low) CPU load and same transfer speed. I also tried copying files in the other direction and I get pretty much the same number of 70 MB/s.


#26

Do you use compression on your volume?
What version of Freenas?


#27

Yes, it is using the standard lz4 compression, but I don't think that the Xeon can't keep up with >70MB/s.

It says "FreeNAS-9.10.2-U1 (86c7ef5)".


#28

Transferring to or from a Windows box?
Watch task manager for bitrate of transfer. I have noticed it normally does better than the one that shows during the file transfer operation.


#29

I am transferring to and from a Ubuntu machine. I checked the menu addon that let's me see total system bandwidth usage and it matches what the file transfer dialog says.


#30

What smb protocol are you using on Freenas. There should be an option for minimum protocol and highest protocol allowed to be used under smb config page.


#31

Minimum is "---------" and maximum is the highest that I can pick, "SMB3_11", but I think "SMB3" was default. However, I tried that before and there is no performance difference.


#32

Well not sure what all you tried but try smb2 for max and core for lowest.


#33

I just tried it, restarted the service and I see the same number.


#34

Its important to point out, that comfreak is running freenas and I am running Ubuntu server LTS 16.04, and we have literally the same issue. So I believe this to be platform agnostic.


#35

Realtek or Intel NICs?


#36

It's an Intel I219 on-board.

$ lspci
[...] Intel Corporation Ethernet Connection (2) I219-LM (rev 31)

#37

Well damn I'm all out of suggestions


#38

Nope wait one more and then I'll shut up.
What switch is between machines and have you tried different cables?


#39

The switch I am using is built in to my ISP's router. It's quite a high-end router, so I don't expect poor performance. There is about 6 ft of CAT5e going to each machine from there. Running iperf gave me 940 MBit/s, which is the theoretical maximum for Gigabit-Ethernet, so I don't think the actual network is an issue. When I transfer files from the same ZFS dataset via WebDAV, I get 110 MB/s.

So my assumption so far is that the SMB share is the limiting factor, either because of bad configuration (however, I didn't really change anything from the default settings) or a problem that everyone has, but no one cares about?


#40

How big of files are you transferring?
Only thing I can think now is export your volumes and re install install freenas..
My freenas 9.10 box would hit around 90-95mb on large files transfers like movies and such.
Lots of small files if I remember would kind of fluctuate from around 35-60 or 70.