Slow FreeNAS SMB read speeds (RAID-Z2)

Hi, ronclark. Thanks for your response. :slight_smile:

This is the output of “sas2flash -list”:
image

and dmesg (yes, the firmware is somewhat older):

I did notice these weird warning messages from dmesg. Are they of any importance to my current predicament?

Firmware: Could a firmware/driver mismatch REALLY cause such issues?
To upgrade the firmware I found this guide:


Obviously I would replace the 9211-8i files with the appropriate 9207-8i files from the official Broadcom page. Seeing as the guide is for UEFI and my FreeNAS’ motherboard does not support it, I was thinking about sticking the HBA in my Windows machine and using the created USB to flash the card to P20. There would still be a mismatch though (FreeNAS driver version: 21; HBA firmware version: 20) but at least it would be up-to-date.

The warnings from dmesg are ACPI firmware, that’s not likely related.

The HBA firmware being vastly different from the driver version is a bit more alarming. 20 vs 21 not a big deal, 7 vs 21 yikes.

2 Likes

I would definitely upgrade the firmware to the latest firmware.
it can done inside BSD and Linux. I did mine on old system booted into freeDOS since i had problems with a UEFI system. I just could not figure it out.
I think the YouTube channel the ArtofServer has some info on how he flashes hba card.
I would be interested in hearing if that fixed your problem or not.

It’s 15 (hba firmware) vs 21(freebsd driver). Not 7 vs 21.

Oh yep looked at the wrong line, I knew that seemed pretty extreme :smiley:
15 vs 21 still is quite a gap though.

I asked the guy responsible for SMB in FreeNAS and he said

The issue requiring those auxiliary parameters is mostly fixed. If he’s doing mostly sequential workload he may be better off setting aio read size = 0 . Try Beta1 to see if performance is better.

I don’t know much about samba myself to tell you how to set that aio read size setting, but there’s probably a samba options thing in FreeNAS somewhere I’d guess.

No idea if this will help or not but I’m also running FreeNAS with RaidZ2 and for the life of me couldn’t figure out why SMB was slower in one direction. After trying to isolate it for a LONG time, I discovered there is a bug in Windows 10 after/including 1809. Made the following key in my registry and SUDDENLY no bottleneck. I realize this post is about 10Gbe and this might not help but:

Regedit

HKLM\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

add

DirectoryCacheLifetime Dword=0

Good luck!

I ran across this and thought it was interesting, it might be helpful

https://www.omelsoft.com/fix-slow-internet-windows-10-creators-update/

https://docs.microsoft.com/en-us/archive/blogs/netgeeks/a-word-about-autotuninglevel-tcp-receive-auto-tuning-level-explained