SLI breaks virtual Desktops under bspwm

Hey guys maybe someone has encountered this problem before but I am having trouble with bspwm and sli.

Basically I have been running Arch with bspwm since my upgrade and it has been working flawlessly so far with one small exception. Once I want to enable SLI I only have one workspace per monitor instead of 5 per monitor even though nothing in my config changes and even when I explicitly tell bspwm which GPU and which monitor to use.

/* ~/.config/bspwm/bspwmrc */
#! /bin/sh

sxhkd -c /home/skl27/.config/sxhkd/sxhkdrc &

bspc monitor GPU-0.HDMI-0 -d I II III IV V
bspc monitor GPU-0.DVI-I-1 -d VI VII VIII IX X

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 440.64

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 440.64

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"

Section "Files"

Section "InputDevice"

    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"

Section "InputDevice"

    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"

Section "Monitor"
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "Ancor Communications Inc VX24A"
    HorizSync       29.0 - 113.0
    VertRefresh     49.0 - 76.0
    Option         "DPMS"

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GTX 970"
    BusID          "PCI:14:0:0"

Section "Screen"

    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "Stereo" "0"
    Option         "nvidiaXineramaInfoOrder" "DFP-1"
    Option         "metamodes" "GPU-f157c663-184c-c35c-fc5f-51e7f43ddd0c.HDMI-0: nvidia-auto-select +0+0 {ForceCompositionPipeline=On}, GPU-f157c663-184c-c35c-fc5f-51e7f43ddd0c.DVI-I>
    Option         "MultiGPU" "SFR"
    Option         "SLI" "SFR"
    Option         "BaseMosaic" "on"
    SubSection     "Display"
        Depth       24

I wasn’t able to find anything helpful online but maybe some of you can help.^^