Skyrim "Failed to initialize renderer. Unknown error creating renderer."

On my new Asus N56JR laptop, whenever I try to launch skyrim, it says "Failed to initialize renderer. Unknown error creating renderer," The laptop is equiped with an i7-4700HQ and a 760m.

I have tried deleting skyrim.ini and skyrimprefs.ini and verifying the cache integrity. I have also tried running as administrator and in compatibility mode. I have also tried turning the sound quality of my speakers down to 16 bit rather than 24 bit. 

I have also tried Fallout new vegas, except the error is "Failed to initialize renderer. Unknown error creating the Gamebryo Render."

Does anybody have any idea how to fix this?

Im on windows 8 (8.1).

(and yes i tried restarting my computer)

I am going to assume that the game has run before.  Now there two things that I would try. First run the game in windows 7 compatibility mode. Second backup the progress data files then reinstall the game, Get it running. Then colse it and replace the backed up files. DO NOT DELETE THE OLD INSTALL UNTIL YOU ARE SURE THAT THE NEW ONE IS WORKING!!! Just move it to a different folder and leave it.

Hope this helps. Please report back.