Skylake Memory Issue

Hey everyone,
I decided to join team blue recently and I upgraded from a fx6300 to the i5 6600k, but when doing the build I had some issues. The first gigabyte board that I bought was DOA and only one of the RAM slots worked. I then went with the MSI z170a gaming m7 which is really great, and I highly recommend it. Though I do want to share a problem that I ran into. I got Windows 10 to install and it was running, but every hour or so I would get a BSOD. After running Memtest86 it came back with errors during test 9. Initially I thought I got some bad ram, but when I took it back and got a new kit I still got the errors in Memtest86. Long story short I figured out that the default voltage was too low and that was what was causing the instability. I turned on the xmp profile and turned the voltage up to 1.35v and that fixed everything. I don't know if anyone else had this problem because I couldn't find anything while searching the web for it, so I just wanted this info out there!

FYI and specs:
i5 6600k
MSI z170a gaming m7
Evga superSC 4x4gb ddr4 2800 (it's basically rebranded g skills ripjaws)
-the first memory I tried was the corsair 2x8gb 2666
Asus R9 290 direct cu ii
Cooler master nepton 240m

Good to note, since a Skylake build is imminent for me. I plan on using G.Skill NT series. I'm not spending a lot on memory, as i only need 8 GBs.

yeah i had same issues on gigabyte x79 2011.

after overclocking it became stable, (because mobo automatically without my approval managed voltages of memory and cpu on defaults) it only became stable once overclocked (by a lot...)

always use XMP!!!! I cannot stress this enough

I tried XMP when I had the crucial ram and it wouldn't even post, even with the BIOS update. I agree though, xmp is the way to go