Return to

Simple solution for installing Manjaro on PCs with Vega GPUs

If you installing the current releases of Manjaro on a PC with Vega 56 or 64 you’ll most likely get stuck at “Started TLP system startup/shutdown” in the boot process when running the installation media

A simple solution is to just download one of the development releases of Manjaro here:

Manjaro has gotten an official solution to this problem since Bruger’s post on the matter, so I thought I’d make an updated post.


I used the architect to install Manjaro/Budgie last week, without too much difficulty. This method allows the user to install whichever kernel is desired and it does, in fact, offer the very latest releases. Honestly, the process is very straightforward, but it is important to go step by step, rather than jumping around. The only issues that I experienced were extremely slow throughput from the repository and, at the end of the configuration process, the installer kept erroneously insisting that I had not yet installed the boot loader.

I’m not suggesting that the guide shouldn’t be updated, but I think it unlikely that anyone who has performed more than a couple of Linux installs, will get stuck and not be able to effect a successful install.

1 Like

Manjaro v18.0.0 update released yesterday with V4.19 Kernel
new install ISOs should be all good for Vega GPU

sudo pacman-mirrors -g to find fastest repositories

everyone updating last couple of days may have slowed them too

1 Like

Never understood why Manjaro installs on Vega broke when other distro installs didn’t.

This problem persisted for a long time. The installer should have been tweaked to do or say something useful. Distributions should not expect users to be aware of notices on their sites or forum posts.

1 Like

Hey guys, so I just got a shiny new Vega VII and I’m having the same issue, the live usb I made is running Kernel 4.19 LTS. I’m guessing that i need to update the kernel for the new vega as well but I tried that by booting into it on another computer and it didn’t take after the reboot. Any ideas on how I can get this to work?

  • go to manjaro-settings-manager
  • select ‘Kernel’
  • find latest stable kernel (currently 5.0.9) and click ‘Install’ button
  • reboot system to load new kernel

it is suggested to keep an older kernel installed in case of any problems with new kernel