Shadowbane"s Networking Journy

I have decided to learn everything there is to know about the subject of Networking. This post is being created to have all my networking questions answered, ask for help when I mess up and document what I have learned.

The best way to start is to give my readers an idea of the Networking hardware and software I am using. I use a Netgate SG-5100 appliance and an Unifi Gen 2 switch; also, I have installed a used Intel I 350 ethernet card into my personnel computer (purpose of installed Intel network card is to add network interfaces for Virtualbox). For networking software, I am using Pfsense (Pfsense is installed on the Netgate SG-5100), Gns3 Networking Simulation software, and Virtual Box to simulate servers.

I am getting internet access for my network by connecting my Netgate SG-5100 to the house’s router. I also have my Desktop connected to the house router and my network by draping two Ethernet cables outside my window. I have included a diagram of how my network is set up.


Virtualbox on its own is great for creating networks, run a bare bones install of ubuntu server on 3 seperate VMs. have the one in the middle a simple router: (router settings) connect them together (VM1 -Net1- Router -Net2- VM2) having a third network on router bridged to computers network can give Internet access and good for running Wireshark. Learn how to use Wireshark/nMap, very useful diagnostics tools.


Thanks for the suggestion, I will try your suggested router setup. I have used Wireshark and Nmap in the past, I am no expert with either, I would use Wireshark more often if its interface was more newcomer-friendly when using Linux.

I deal with many office networks, Linux and Wireshark have help me through almost impossible problems. I use Simple tools also Advance Port Scanner, Slitheris NetScan and the command line for quick checks.
I am still no expert, I still have to google command lines, the Internet is your cheat sheet. :wink:
pfsense can help with router operating system, its got a graphical interface has network tools for troubleshooting, good for a VM.

2 Likes You might want to reread the original post; I just finished editing it. I included more information on how I have my Netgate SG-5100 is connected to the internet.

I have learned something interesting that I forgot to share in my previous posts. It is possible to replace Cincinnati Bell’s provided router with an ASUS RT-AX88U router. I have been running the ASUS RT_AX88U for about six months, all without a modem. In other words, I have the ASUS RT-88U connected to the outlet provided by Cincinnati Bell, no other device between the ethernet cable and the RT-88U, and I didn’t have to call Cincinnati Bell to make any network changes on their end. I set up the RT-88U by connecting the ethernet cable from the wall into the Wan port on the back of the RT-88U and turned it on. Then ran the default setup program and followed the prompts. I decided to post about my discovery that the RT-88U will provide Internet access without any other device needed, in case someone else is looking to replace Cincinnati Bell’s provided device with something else.

Study the OSI model. Don’t worry too much about layers 6-7. Master layers 2-4.

1 Like

Thanks, everyone, for the advice; it has been beneficial.

As promised, I am blogging about every networking discovery I find. To that end, this post is about how I solved my first networking setback I have come across. I followed a guide written by David Bombal on installing Cisco Virl appliances using Virtualbox as the hypervisor to host GNS3 VM. Meaning I was trying to get GNS3 Server and GNS3 VM to all run on the same machine. It was quite a challenge; the reason it was challenging is THe instructions are for Windows only, and I had to figure out how to adapt the guide for Linux since Kubuntu is the only operating system on my computer, without knowing a lot about how Linux works. I know many readers of this forum would say adapting a guide designed for Windows should be easily adapted to work on Linux; well, the installation instructions were easy; fortunately, the GNS3 community as installation instructions on their web site on how to install the GNS3 program and GNS3 server on all the major Linux operating systems. The problem didn’t lay with installing GNS3 on Linux but with the program not working as it should after everything was installed. I would find a solution that seemed to fix one error, but a different error would take its place. I tried to uninstall GNS3 and reinstall it eight different times completely, but the result would be a different error; finally, at the last try, the original error showed up (the error had to do with the GNS3 server and the GNS3 VM being on different networks.) instead of trying one more time uninstalling GNS3 and then reinstalling it I did a quick Google search and found some article that mentions the GNS3 server and the GNS3 VM need to be on the same network, as soon as I change the network the GNS3 Server was on to the one the GNS3 VM was on all my problems went away, at least so far.

1 Like

Hi @oO.o and, I am sorry to bother you, but I was too optimistic about fixing my errors with GNS3. It was working very well yesterday, but today, I get the following errors when I tried to use GNS3 today.

Timeout after 5 seconds for request http://[email protected]:3080/v2/version. Please check the connection is not blocked by a firewall or anti-virus.

Could not bind with [Errno 99] Cannot assign requested address (please check your host binding setting in the preferences)

Could not start the local server process: /usr/bin/gns3server

Because GNS3’s debugging files are extremely long, I had to upload them as files.
Here is the debug filedebug.txt (27.3 KB).

Here is GNS3’s Controller Conf file gns3 controller.txt (5.9 KB).

Here is the GNS3 GUI Conf file gns3_gui.txt (4.3 KB).

Here is the GNS3 Log File gns3_gui.log.txt (1.1 KB).

Here is GNS3’s Server Conf file gns3_server.txt (695 Bytes).

Here is GNS3’s Server Log file gns3_server.log.txt (7.9 KB).

If you guys could help me or know someone who can, please help me get in touch with them. If you or anyone else needs more information, just let me know. I know the GNS3 community recommends VMware Workstation Pro over Virtualbox. Still, if I can avoid spending any more money (I have spent too much money already on my network), I would really appreciate it.

1 Like

No experience with gns3 and not much experience with virtual OC so idk if I can help you with that specifically.

Thanks for the reply @oO.o; I have narrowed down the problem. The GNS3 GUI is changing the network bindings to localhost instead of the Network address I assign in the network binding options. So my choices to fix the issue are either restart my computer and manually reset the network binding or figure out how to force GNS3 GUI not to change my network bindings. I might manually change the GNS3 GUI Conf file or the GNS3 Server Conf file to fix the issue.

1 Like

It may be something is using port 3080 or has legacy instance that hasn’t terminated yet.
Do netstat -a look for the port number
See what PID is running and kill it

The software, is it being connected to remotely and is that traffic getting to the VM? You’ll find something in the pipeline that is affecting the startup.

As I’m unsure of the software, http://[email protected]:3080/v2/version does not look right, is your browser diverting to https? (what’s getting me is the /v2/version at end)

Sorry,, I haven’t been able to get back to you until now, Work has been very buzzy, and it looks like it will worsen before it slows down again. I did a Netstat -a in the terminal looking for some prosses using port 3080, but I couldn’t find anything using that port number. I didn’t find a process running in the pipeline that would be interfering with GNS3 or GNS3’s VM. I am hosting a GNS3 client (GNS3 Server) on my Kubuntu 20.4 desktop with a GNS3 VM running inside Virtualbox 6.1.1. Everything is running locally on my Kubuntu 20.4 desktop.
‘’‘Http://[email protected]:3080/v2/version’’’ didn’t look right to me also until I read an article stating the software developers of Ubuntu decided to change the way you bind virtual nic’s, I don’t understand why they made the change or how it works (at least not yet), but that is the correct contexts. I even changed the hypervisor I was using to Vmware Workstation, but I am getting different error messages. The biggest one I am stuck on right now is ‘’‘Can not connect to the internet URL open error [erro-31] Temporary failure in name resolution.’’’
I tried researching what that error message means on google but didn’t find an answer. I guess the next step is to contact the GNS3 developers and see if they can help me. I feel the problems I am having with GNS3 will be because the Linux version of GNS3 is still very experimental and not ready for primetime. Thanks for trying to help.

Had a quick look at gns3, not something I had starting out.

It looks like a network config issue:
DNS is unreachable or Gateway is unreachable/incorrect

Look at the network setting of the VM:
NAT may need to change to Bridged or vice versa.
On VirtualBox there is a setting to allow VMs to talk to host, been 2+ years since used VMWare cannot remember if possible or needed.

A tracert to or Ping gateway, local machine, router and a website to see where it stops.

Thanks for the quick reply, Success all I had to do was pick one of the two virtual NICs (GNS3 VM VMware version) already assigned to GNS3 VM, change it to bridge mode, and assign an IP address that can reach the internet to the virtual NIC. I ping the router and Google, and the ping was successful, so now one less problem.

1 Like