SFP+ Connection for Intel 82599 10GB to MicroTik CSS610-8G-2S+IN

Hey all first time posting here.

TLDR: For a DAC switch to Intel NIC connection how can you work out which DAC cables to buy?

I’ve been upgrading the connection I use for my home setup I use for ML research. I recently got a QNAP NAS ( TS-h886) as I was running out of space to store all my model data. I wanted to use 10 GB networking between my main desktop/server I use for training and the NAS.

I have 2 CSS610-8G-2S+IN connected via a OM3 active fibre-optic cable (the green one) that seems to work fine. I then got 2 of the Intel X520 82599 NICs from amazon ( 10Gtek® 10GbE PCIE Network Card for Intel X520-DA1-82599EN Chip, Single SFP+ Ports, 10Gbit PCI Express x8 LAN Adapter, 10Gb NIC for Windows Server, Win8, 10, Linux). (sorry I can’t link yet.)

  • In the QNAP NAS the card doesn’t seem to be recognized do I need to buy QNAP manufactured SFP+ NICs for QNAP NAS’s?

  • Is the type of DAC SFP+ connector important I have tried the following cables:

    • SFP-H10GB-CU3M
      (10Gtek 10Gb/s SFP+ DAC Cable 3m - 10GBASE-CU Passive Direct Attach Copper Twinax SFP+ Cable Compatible for Cisco SFP-H10GB-CU3M, Ubiquiti, Netgear, D-Link, TP-Link, Zyxel, Mikrotik, Open Switch) the initial DAC cables I purchased
    • XDACBL3M (10Gtek for Intel SFP+ Cable XDACBL3M 3-Meter(9.8ft), 10Gb/s SFP+ Direct Attach Copper Twinax Cable, Passive) the second cable I bought, thinking this was to do with the intel NIC requirements

To try and debug my desktop I ran the following:

On Ubuntu (20.04) side:

>> ethtool enp74s0
Settings for enp74s0:
	Supported ports: [ FIBRE ]
	Supported link modes:   10000baseT/Full 
	Supported pause frame use: Symmetric
	Supports auto-negotiation: No
	Supported FEC modes: Not reported
	Advertised link modes:  10000baseT/Full 
	Advertised pause frame use: Symmetric
	Advertised auto-negotiation: No
	Advertised FEC modes: Not reported
	Speed: Unknown!
	Duplex: Unknown! (255)
	Port: Direct Attach Copper
	PHYAD: 0
	Transceiver: internal
	Auto-negotiation: off
Cannot get wake-on-lan settings: Operation not permitted
	Current message level: 0x00000007 (7)
			       drv probe link
	Link detected: no

For the NIC:

  modinfo ixgbe
filename:       /lib/modules/5.11.0-41-generic/updates/drivers/net/ethernet/intel/ixgbe/ixgbe.ko
version:        5.13.4
license:        GPL
description:    Intel(R) 10GbE PCI Express Linux Network Driver
author:         Intel Corporation, <[email protected]>
srcversion:     7CB7CA8F1172680EA2FCA44
alias:          pci:v00008086d000015E5sv*sd*bc*sc*i*
alias:          pci:v00008086d000015E4sv*sd*bc*sc*i*
alias:          pci:v00008086d000015CEsv*sd*bc*sc*i*
alias:          pci:v00008086d000015CCsv*sd*bc*sc*i*
alias:          pci:v00008086d000015CAsv*sd*bc*sc*i*
alias:          pci:v00008086d000015C8sv*sd*bc*sc*i*
alias:          pci:v00008086d000015C7sv*sd*bc*sc*i*
alias:          pci:v00008086d000015C6sv*sd*bc*sc*i*
alias:          pci:v00008086d000015C4sv*sd*bc*sc*i*
alias:          pci:v00008086d000015C3sv*sd*bc*sc*i*
alias:          pci:v00008086d000015C2sv*sd*bc*sc*i*
alias:          pci:v00008086d000015AEsv*sd*bc*sc*i*
alias:          pci:v00008086d000015ADsv*sd*bc*sc*i*
alias:          pci:v00008086d000015ACsv*sd*bc*sc*i*
alias:          pci:v00008086d000015ABsv*sd*bc*sc*i*
alias:          pci:v00008086d000015B0sv*sd*bc*sc*i*
alias:          pci:v00008086d000015AAsv*sd*bc*sc*i*
alias:          pci:v00008086d000015D1sv*sd*bc*sc*i*
alias:          pci:v00008086d00001563sv*sd*bc*sc*i*
alias:          pci:v00008086d00001560sv*sd*bc*sc*i*
alias:          pci:v00008086d00001558sv*sd*bc*sc*i*
alias:          pci:v00008086d0000154Asv*sd*bc*sc*i*
alias:          pci:v00008086d00001557sv*sd*bc*sc*i*
alias:          pci:v00008086d0000154Dsv*sd*bc*sc*i*
alias:          pci:v00008086d00001528sv*sd*bc*sc*i*
alias:          pci:v00008086d000010F8sv*sd*bc*sc*i*
alias:          pci:v00008086d0000151Csv*sd*bc*sc*i*
alias:          pci:v00008086d00001529sv*sd*bc*sc*i*
alias:          pci:v00008086d0000152Asv*sd*bc*sc*i*
alias:          pci:v00008086d000010F9sv*sd*bc*sc*i*
alias:          pci:v00008086d00001514sv*sd*bc*sc*i*
alias:          pci:v00008086d00001507sv*sd*bc*sc*i*
alias:          pci:v00008086d000010FBsv*sd*bc*sc*i*
alias:          pci:v00008086d00001517sv*sd*bc*sc*i*
alias:          pci:v00008086d000010FCsv*sd*bc*sc*i*
alias:          pci:v00008086d000010F7sv*sd*bc*sc*i*
alias:          pci:v00008086d00001508sv*sd*bc*sc*i*
alias:          pci:v00008086d000010DBsv*sd*bc*sc*i*
alias:          pci:v00008086d000010F4sv*sd*bc*sc*i*
alias:          pci:v00008086d000010E1sv*sd*bc*sc*i*
alias:          pci:v00008086d000010F1sv*sd*bc*sc*i*
alias:          pci:v00008086d000010ECsv*sd*bc*sc*i*
alias:          pci:v00008086d000010DDsv*sd*bc*sc*i*
alias:          pci:v00008086d0000150Bsv*sd*bc*sc*i*
alias:          pci:v00008086d000010C8sv*sd*bc*sc*i*
alias:          pci:v00008086d000010C7sv*sd*bc*sc*i*
alias:          pci:v00008086d000010C6sv*sd*bc*sc*i*
alias:          pci:v00008086d000010B6sv*sd*bc*sc*i*
depends:        dca
retpoline:      Y
name:           ixgbe
vermagic:       5.11.0-41-generic SMP mod_unload modversions 
parm:           IntMode:Change Interrupt Mode (0=Legacy, 1=MSI, 2=MSI-X), default 2 (array of int)
parm:           InterruptType:Change Interrupt Mode (0=Legacy, 1=MSI, 2=MSI-X), default IntMode (deprecated) (array of int)
parm:           MQ:Disable or enable Multiple Queues, default 1 (array of int)
parm:           DCA:Disable or enable Direct Cache Access, 0=disabled, 1=descriptor only, 2=descriptor and data (array of int)
parm:           RSS:Number of Receive-Side Scaling Descriptor Queues, default 0=number of cpus (array of int)
parm:           VMDQ:Number of Virtual Machine Device Queues: 0/1 = disable (1 queue) 2-16 enable (default=8) (array of int)
parm:           max_vfs:Number of Virtual Functions: 0 = disable (default), 1-63 = enable this many VFs (array of int)
parm:           VEPA:VEPA Bridge Mode: 0 = VEB (default), 1 = VEPA (array of int)
parm:           InterruptThrottleRate:Maximum interrupts per second, per vector, (0,1,956-488281), default 1 (array of int)
parm:           LLIPort:Low Latency Interrupt TCP Port (0-65535) (array of int)
parm:           LLIPush:Low Latency Interrupt on TCP Push flag (0,1) (array of int)
parm:           LLISize:Low Latency Interrupt on Packet Size (0-1500) (array of int)
parm:           LLIEType:Low Latency Interrupt Ethernet Protocol Type (array of int)
parm:           LLIVLANP:Low Latency Interrupt on VLAN priority threshold (array of int)
parm:           FdirPballoc:Flow Director packet buffer allocation level:
			1 = 8k hash filters or 2k perfect filters
			2 = 16k hash filters or 4k perfect filters
			3 = 32k hash filters or 8k perfect filters (array of int)
parm:           AtrSampleRate:Software ATR Tx packet sample rate (array of int)
parm:           FCoE:Disable or enable FCoE Offload, default 1 (array of int)
parm:           MDD:Malicious Driver Detection: (0,1), default 1 = on (array of int)
parm:           LRO:Large Receive Offload (0,1), default 0 = off (array of int)
parm:           allow_unsupported_sfp:Allow unsupported and untested SFP+ modules on 82599 based adapters, default 0 = Disable (array of int)
parm:           dmac_watchdog:DMA coalescing watchdog in microseconds (0,41-10000), default 0 = off (array of int)
parm:           vxlan_rx:VXLAN receive checksum offload (0,1), default 1 = Enable (array of int)

In the GUI it just shows the cable as disconnected and I can’t press the switch button in the settings app.

On Windows 10 using the Intel test tool:

  • The hardware test shows all tests passed
  • The connection test fails with: Adaptor does not have a link make sure the cable is connected

Thanks for everyone’s help :grinning: !

Hmm … i’ve never known an actual Intel branded card to be pick. HP branded Intel cards on the other hand, oh boy.

I have a 10GTek 1m dac cable at home, came with a pair of Intel x520’s I bought from eBay. Works fine between the cards, also works fine to my Mikrotik switch.

I would try a cable from FS or Proline Options, they seem to be a step or two above 10GTek in terms of quality. You know your card is good since it works with the optics, so sounds like you’re just having bad luck, maybe defective or counterfeit cables?

Thanks for your help, I’ll look at ordering some of the FS cables. Also should have said, on the switch I get the following display does this suggest it is counterfit as the switch appears to have detected the correct cable. (this is with SwOS Lite) I can’t turn off auto-neg as only 1G, 100M and 10M are options but I understand the NIC only accepts 10G conns and can’t downgrade.

The x520 will do 1G as well, when connected to a compatible SFP module. Intel Ethernet Converged Network Adapter X520DA1 Product Specifications

Hopefully a new cable with get your connection working the way you need it.