Return to Level1Techs.com

Settings won't launch(gnome-control-center)

As the title states I can’t get settings to launch. This is what I get from the terminal.

[email protected]:~$ gnome-control-center

(gnome-control-center:6267): GLib-GIO-ERROR **: 12:36:36.451: Settings schema ‘com.system76.hidpi’ is not installed
Trace/breakpoint trap (core dumped)
[email protected]:~ sudo gnome-control-center [sudo] password for kinsman: ** ERROR:../shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid) Aborted [email protected]:~

I’ve tried removing gnome-control-center and reinstalling it but I get the same errors. After reboot display background and lock screen are gone, I assume because of the gnome-control-center remove and reinstall. Thanks in advance to anyone that could help or has ideas.

Is this a system76 laptop?

It would be useful to know what OS, is it up to date, any particular tweaking you did.
output of journalctl -xb -p err

If you removed gnome-control-center you might have to reinstall the gnome metapackage or the OS’ metapackage.

Yes, the problem with removing the package to reinstall it is that you’re also uninstalling everything that depends on that package. Reinstalling the package does not bring back it’s dependents.

This is a Fx 6300 based desktop I built myself a few years ago. I’m running Ubuntu 19.04 and noticed the settings issue after trying to install GLXOSD with no success.

[email protected]:~$ journalctl -xb -p err
– Logs begin at Sat 2019-04-20 00:30:23 PDT, end at Wed 2019-04-24 14:20:40 PDT. –
Apr 24 13:45:33 fxdesktop kernel: Couldn’t get size: 0x800000000000000e
Apr 24 13:45:37 fxdesktop spice-vdagent[1297]: Cannot access vdagent virtio channel
Apr 24 13:45:44 fxdesktop gdm-password][1518]: gkr-pam: unable to locate daemon cont
Apr 24 13:45:48 fxdesktop spice-vdagent[1860]: Cannot access vdagent virtio channel
Apr 24 13:45:55 fxdesktop gnome-session-binary[1064]: Unrecoverable failure in requi
lines 1-6/6 (END)

Also how to I put the terminal commands in the box?

So am I just screwed and have to reinstall the whole OS. This will be my third time, after running into problems I can’t figure out or can’t find help online. I really want to learn Linux but I’m starting to lose faith. I keep running into problems, not knowing enough to fix myself and unable to find any advice.

Hold off on reinstalling. You should be able to just force install the desktop metapackage and get all of the dependencies back. I don’t know what the metapackage is called though, as I don’t use Pop or gnome

Alright I’ll see if I can figure out the metapackage and dependencies. Thanks for the help

According to Ubuntu here, https://packages.ubuntu.com/disco/gnome-control-center, you need “gnome-control-center” and “gnome-control-center-data”.

Between the two above, you apt should pull in the dependencies.

apt update && apt install -f gnome-control-center gnome-conrol-center-data

The -f is to fix what ever is broken or partially installed in the current installation. You may need to switch to an actual tty.

1 Like

Still having the same issue and same output in the terminal as my original post.

$ gnome-control-center

(gnome-control-center:11728): GLib-GIO-ERROR **: 15:18:07.196: Settings schema ‘com.system76.hidpi’ is not installed
Trace/breakpoint trap (core dumped)

$ sudo gnome-control-center
[sudo] password for kinsman:
**
ERROR:…/shell/cc-shell-model.c:458:cc_shell_model_set_panel_visibility: assertion failed: (valid)
Aborted

Install the following:

sudo apt install hidpi-daemon

It’s required because of latest Pop! OS improvements:
https://pop-planet.info/2019/04/this-week-in-pop-9/

6 Likes

It worked!

It helped me. But it was already installed. But when reinstall it, it told me that is already installed. But after that it start working again. Thanks anyways.

awesome, this was my issue. You rock!

man, thank you, it is worked for me!