Setting Drives to use the FAT32 File System

So, I’ve tried to format my drive that’s 64 GB to use the FAT32 file system using command prompt as administrator, but I haven’t had any luck. I keep receiving this error message saying that the drive is too big. I know it’s possible to get the drive to use the FAT32 file system because I have done it using OS X/macOS, but I’m not having luck with Windows.

Any native based solutions?

Sounds like you’re trying to format it in FAT16 (maximum size of 4GB) rather than FAT32. Do you have to use the command prompt? Because you can just right click on it and select format.

No, I’m using FAT32.

The option for FAT32 does not show up upon right clicking it.

What options do show up?

Yeah Windows is somehow inhibiting the possibility to format drives larger than 32GB FAT32.
If you want to do it download an external tool like EaseUS or something similar. This will work 100%.

P.S. you can also use Partition Wizard. I’ve tested both of those programs and they work well.

Just use admin powershell or CMD.

format “driveletter:” /FS:FAT32

Or just use exFAT like a human, you crazy animal you!

Wendell, please help

I seem to recollect having the same problem some years ago, if i remember correctly it is because M$ requires you to format any drive over a certain size as NTFS instead of fatxx, there’s no reason why except they want you to.
You can allways boot a linux live disk and do it, since 64 gigs is very well within fat32’s specs.
I’ve the past i have had great success using
for disk management in windows.

It’s strange because I’ve seen 3rd party software be able to do it in Windows, but not Windows itself. It seems like from that it should be possible. I wonder if we’re missing something.

You’re not, like i said, there is no reason to why not, other then they really don’t want you to.
fat32 support 2TB partitions i believe, please correct me if i am wrong though, but M$ in their ungodly wisdom has set a limit at 32gb(i think), where the OS insists you use ntfs.
my guesses lies in optimization problems, since fat32 is slow as …, and the fact they really want to enclose their users in a very predictable environment, which is the exact same problem we had when windows 10 was first released where they tried to force feed the users that platform to the point of getting sued and loosing.

It’s true, Windoze makes it difficult (impossible?) to format volumes larger that 32 GB as FAT32. I ran into this when trying to format a 64 GB flash drive (it had to be FAT32, homebrew Wiis can’t read exFAT…). Honestly just boot up a linux usb and run GParted or fdisk.

Note that Windows has no problem reading these large FAT32 partitions once they’re made. It just won’t let you.