Sabertooth X99 unlisted (seemingly random) beep codes [solved]

This happens every so often with no obvious cause or logical fix. My motherboard just beeps at me, tries to boot and usually fails. Eventually it starts working again (it has done since recording this video).

I’d like to hear your guys’ thoughts on what this is. My CPU is usually running at 4.6GHz at 1.345V (5820k), but for the purpose of debugging , I set everything to auto and removed all but one stick of the quad channel memory kit I am using. I also swapped that stick with another one but with the same result.

The beep messages can go on for up to four minutes before finally stopping. They are always varying combinations of 3 short beeps, 4 short beeps, and 5 short beeps.

Take a look, I’d love to hear what you guys think this is, because I’m stumped

EDIT: I removed a HDD which seemed to get us booting consistently. However, the beeping remains…

EDIT: Nearly an entire year later, I’ve finally solved the issue. It was my fan controller beeping, not my motherboard… Now, this does raise several more questions:

  1. Why does a fan controller have beep codes?
  2. Why aren’t they mentioned anywhere in the manual?
  3. Why does a fan controller need a speaker?
  4. Why did this only occur when the PC was booted within roughly an hour of it previously being shut down?
  5. Why did it happen more when the CPU was running at a higher voltage?

This has been a sad year and I will never be able to erase the horrendous beeping from my mind. I have now dedicated my life to going after the person/people who made the fan controller in a ‘Kill-Bill’-esque quest for vengeance.

Thanks to those of you who tried to help last year.

That is the noise my alarm clock makes.

No idea.

I've seen on the Asus website that you have on that board a TUF USB port that's able to display a post code through an app. Try to get that and see what's the post code displayed so you can get a better understanding of what's happening.
Yeah the beeping is making it's not comforting at all. Could even be morse code, who knows lol (surely it's not the SOS signal in morse code).

1 Like

All I can dig up with that repeated beeping is "Hardware Component Failure." Thanks ASUS. Way to document the issues.... grr.

I've never worked on a X99 system, and I've never seen a MB still beeping once booted up. Normally those beep codes happen when you can't pass POST, or a single beep if you pass POST no problem.

Aside from systematically removing parts like graphics card, memory, whatever add-on's (like Wifi) I am at a loss. Just for giggles, load up Memtest86+ (link: At least we can narrow down that it isn't a RAM issue.

Sorry, I'm at a loss. Might have to RMA something, and that sucks the big one.

Beeping sounds like a ram issue to me.
Sounds like that it has some issues with either your memory modules or your overclock.
I would firstly try to update the bios to the newest version if not done allready.

I updated the bios and ran memtest, as per your suggestion, for 7 and a half hours without a single error. I've been running a stock speeds for a few days and have still had intermittent "beepy boots". I have had a few video card crashes. I have had a few video driver crashes that may or may not be related.

The big issue here is, there isn't anything malfunctioning, just beep messages with no real fault attached. Everything works fine and I can't narrow down the source of the problem to RMA the component that's causing the MOBO to beep. :/

To be fair, and not tring to be a jerk here or anything, but the source of the problem for a RMA is the beeping. That's not normal behaviour. You've done everything I would say is reasonable to try to isolate the issue, so the next step would be replacing the MB while it's under warranty (and if I am not mistaken those TUF series boards have a 5 year warranty). I mean the last thing to try before RMA'ing the MB would be to remove the video card from the equation completely. Assuming you have a spare video card or a friend can loan you one.

I hope this works out for you. I'm kind of at a loss.

Well as far as i know the X99 Sabertooth does not have a speaker on it right?
So technically the board couldnt send beep codes.

I suppose its another device thats causing problems.

i will check you video closely later.

The sabertooth board doesn't have an LED display. I believe that's only the ROG boards. I certainly don't think it's the video card sending beep codes! So it must be the mobo.

I've tried tweeting at asus about it. I'm also going to send them an email I think. If it's possible for me to fix the issue myself, rather than RMA a board that works (more-or-less) that'd be preferable. I do still need to try swapping out the video card. It's going to be a bit tricky to balance the existing card as it shares the same loop as the CPU without much slack on the tubing. I guess I should just be thankful I chose soft rather than rigid tubing!

After a quick google search it looks like some video cards can send out beep codes. Who knew? Maybe google your particular make/model of GPU and see if it is capable of it?

Well the PCB doesn't have a speaker on it. I recorded myself installing the water block on it when I first got it in-case something like this happened. (brownie points for me!)

As far as I can tell, it shouldn't have any beep codes. It's a reference GTX 980 from OverclockersUK. There is nothing on google I could find about any 9xx video cards beeping themselves. Several video card related motherboard beeps, mind.

I'm fairly sure at this point it's video card related. Unfortunately, I can only really fit a low profile card in the gap left between the tubing and the water block. I'll have to nick one from someone if I find anybody who has one. I did a stability test today using 3DMark and it was 98% stable with no driver crashes. But it's the only piece of hardware that's doing anything uncharacteristic. So that is what I think I'm going to be testing. I really wish I understood what the beep codes meant though. I'm at a real loss on where to look next on this :/

Necro bump of 354 days (holy balls, that took a while) I’ve finally solved this issue. OP updated with explanation.