Sabayon install issues

Hi all,

I'm in the process of reinstalling my os' on my devices. Having installed arch successfully on my notebook I move onto my desktop.

I installed opensuse without a hitch but really wasn't satisfied with the package management then I remembered sabayon which I had installed on the computer a while ago. the only change is my cpu from 3570k to e3 1230 v2 Xeon 

trying to install sabayon on my desktop whether it be cd, USB using unetboot or the virtual clone on my zalman ve 300 all results in failure.

I reach the main menu and upon selecting an option any option the screen goes black or I'm left with a blinking cursor

on the zalman boot if I select start sabayon it i notice the hard drive is asleep

i have no issues booting any other distributions and have tried multiple desktop environments of sabayon.

any help is appreciated 

Sabayon uses proprietary drivers by default. Problem with that is that the kernel can set no mode.

So the first time you use the liveCD, you have to select "run in safe mode" from the grub menu.

Then it will start without problems, and you can install Sabayon from the live session.

Once installed, the initramfs will be adapted to your system, whatever graphics drivers you choose to use, and it will boot up without problems.

I had issues trying to install the 64bit version but no problems with the 32bit. My issue could of been the result of a dodgy usb flash disk though as I had a similar problem installing Manjaro.

Yup, you have to be careful when fabricating a live USB stick. A USB stick isn't seen by linux in the same way Windows for instance sees it. Best thing to do is to make a USB stick with a linux distro, not with Windows, and to rewrite the MBR and reformat it completely with a complete block check.

Then replug the USB drive so that the kernel is informed of the change, and remount.

Then dd the iso onto the USB.

It all depends on the distro or OS you're using to write the USB drive, and the BIOS of the PC you're going to use the USB stick with.

I realiased its the graphics error as last time I remembered I didn't have my 7970 in because it broke for a month for some reason. 

Im booting uefi and I went to advanced options and there was some amd option so I clicked and it booted to the live desktop no issues. I successfully installed however when I restarted grub worked fine and sabayon came up as an option which sleeve fed however that went to a black screen. The monitor was receiving input but nothing was displaying so I'm assuming its still graphics. What do I need to do

I reinstalled and surprise it booted so I did all the updates I restarted and surprise its black screening again. So I tried to boot in recovery mode and it says 

error: [ 0.000000] Fast TSC calibration failed

so no clue

Hey man,

That sounds like a kernel problem. Can you reach the bootloader? If so, try to boot with a different kernel if your bootloader supports it. Also, try booting with some flags (like we did when we used iAtkos), see if that alleviates the problem.

Boot loaders fine it shows no problem every time. What I don't understand is why it works sometimes and not others. Not sure how to change kernel. 

Which bootloader are you using?


Either hold down SHIFT when you turn the computer on or press ESC to load the bootloader menu. You should have the option to change the default kernels using the arrow keys.

If worst comes to worst, try re-installing Sabayon.

One thing that keeps popping up is no iscsi iniitator found 

  • the boot loader only has sabayon or advanced options which include recovery mode no kernal options

iSCSI is a network standard, so it doesn't affect the booting process of your operating system.

TSC is a register on your processor that counts the number of CPU clock cycles since you restarted the computer. So if the synchronisation is failing, then I am lead to believe it is definitely a kernel issue since the kernel is the interface between your CPU and the operating system.

If you can't change the kernel from the bootloader, I would try re-installing Sabayon and ensure the right instruction set is used (amd64 I think for your Xeon CPU) and also make sure the kernel is compiled properly (I don't know the installation process of Sabayon though).

I reinstalled and it booted fine so it's only after updates that issues occur. There was a kernal update in there so I'm assuming that's the problem. Sabayon is a gentoo derivative so I'm hoping its the same because there seems to be loads more documentation for gentoo.

Last I checked gentoo and Sabayon are using different repository, so it might be something gentoo already solved or something that never occurred there.

If you can copy your kernel image from your /boot before updating, or if you can force the package manager in sabayon (is it portage or do they use another tool as well?) not to overwrite your kernel you will be able to boot your old kernel simply by adding an entry to grub. On grub 2 i think this was done either automatically or by editing one of .conf files last time I used grub was about 2 years ago sorry.

Two thing:

- "Fast TSC calibration failed" means nothing at all, that's not where the system is locking. Remove "quiet" from your boot parameters and you'll get a better idea;

- try booting with the old kernel if after an update a kernel fails. 8/10 times, it's because you have an nVidia GPU and those proprietary kernel modules fail to compile in the kernel again. Boot up with the old kernel (one line down in GRUB) and look in the Gentoo/Sabayon fora when the patch is available.

- Use Grub2 only if you have UEFI BIOS, otherwise use GRUB.

I'm using uefi and a 7970 so not nvidia.

Is the quiet parameter meant to be after GRUB_CMDLINE_LINUX_DEFAULT because its not there.

I'm not sure how to add the old kernal entry into grub

Do not use anything else than the AMD beta drivers from AMD directly for AMD GPUs. Reason for this is that the dude that provided the AMD packages for bleeding edge distros was a Fedora dude, thus RedHat, thus now in the nVidia camp, and they've orphaned Catalyst, so there will be no matching update available when the kernel updates. I've mentioned this before on the forum. Download the AMD BETA driver from, and install that (it comes with an installer). It will save you a lot of trouble. Catalyst doesn't crash with every kernel update, at least the AMD BETA version doesn't. The beta driver for linux has a lower version number, but it's not the same versioning system as the release driver, it's actually more recent and has more functions.

The line for older initramfs versions (leading to an older kernel boot) should be in grub automatically, unless you've removed them or have set your package manager to always clean older kernels immediately when updating. If that's the case, manually install the older kernel from your package manager, and dracut a new initramfs, then rectify the driver situtaion, then switch to the newer kernel again, and it will work.