Ryzen front panel sound issue

First off I'm running R7 1700x + Crosshair 6 Hero with Mint 18.1, 4.10.1 kernel. Rear I/O Sound works and everything is fine however the front panel sound doesn't seem to be working even looked at the connection on the motherboard to make sure it wasn't something stupid that I did by accident. The OS sees that the headphones are plugged in but there is no sound, or the sound will simply play for a half second and then stop very strange. I heard wendell saying that sound was working in linux. Maybe I just haven't done something right or the 4.10 kernel is causing issues with the headphone jack in Mint not so sure. Any advice appreciated thanks in advance.

have you verified that it works/breaks on other distro/windows yet?

Actually I have not, I'll have to check that out. Wouldn't have thought to do something like that. Thanks for the tip.

Must be a setting or a connection though, have not had any sound issues on two Ryzen machines, and those were never infected with Windows, so works out of the box in linux.

Do you have a multimeter? Measure out the jack, because those mini stereo jacks sometimes act up.

Read the OPs edit on the Mint forum

He solved his problem by opening alsamixer and doing something in their.

Figures lol, always forgetting to set the output, always forgetting to set the channel config... the scars of pulseaudio sigh...

1 Like

From what I can see the options are different, probably a different version of alsa mixer. There's an option called auto mute and that gets audio working however the speakers are still active hmm.

I noticed that that the thread was from 2014, but I still had hopes that the alsamixer back then was similar to the new version mint has now.

If plugging in the headphone jack in the front doesn't cut the jack in the back, then it's almost certain that you have an electrical problem of some kind, either with the internal connector not fully making contact, or with the jack in the front having a misplaced pin. Measure the jack in the front out with a multimeter, both unplugged and plugged, and see if all connections work.

I'll be sure to do that but when plugging in the headphones speakers stop producing sound. Just no sound out of the front connector. The OS knows I'm plugging in headphones. Confirmed with alsa mixer. Disabling auto_mute enables sound from the headphones but keeps speakers active. Sorry didn't specify.

After setting auto mute to disabled, did you reboot?

Yes. Makes no difference.


Audio does not play from the headphones with auto mute enabled but plays when it's disabled. But of course when it's disabled, it plays from the speakers as well. Which is normal, btw after looking at online documents.

From what I seen online, people have issues where the headphones and speakers both play audio at the same time. To get around that, the user enables auto mute, and then that solves their problem. By having the sound transmitted to the headphones when they are plugged in and not to the speakers and vice versa. But for you enabling auto mute does not allows you to hear audio from your headphones.

I would assume maybe a driver issue? Or setting auto mute to line. Setting auto mute to line solved audio problems for some people. But that was for older versions of alsamixer, I do not know if the option to change to line is their anymore.

Other then that I do not know. Unless their is some magic Intel related sound package that needs to be installed.

I do know that their are tons of people who had this issue. Most of the threads and info on it is quite old, like pre 2015.

Looking into this issue has made me think that audio and alsa is so confusing, and I think I confused myself.

Yeah I looked at the card and driver being used. This driver seems to be the driver that's being used for most sound cards atleast the ones I've searched and came across of threads with issues. I do not know of any other drivers for this card, I assume this is all taken care of by the kernel. I know that 4.11 is adding some audio codecs which may be the issue but I'm not sure. 4.10.1 is bleeding edge enough for me, until 4.11 becomes stable I'm not touching it. I'm just happy that I got my system up and running. It's a minor issue at best but still.

Card-1 Advanced Micro Devices [AMD] Device 1457
driver: snd_hda_intel bus-ID: 2b:00.3

Issue is solved it was just the motherboard. It bricked and I went with another board and processor. Even got cash back from my original purchase all in all a win.


badabing bada boom