Ryzen 3700X Troubles

I’ve just recently built a new system with a ryzen 3700x with an Asrock X570M Pro4 with 64gb ram and a 500gb nvme boot drive plus an additional 6tb hdd for mass storage with a Radeon 5700XT. My memory modules are

Corsair Vengeance LPX 32GB (2x16GB) 2400MHz CL14 DDR4 which i have in matched pairs.

the build went fine and it all boots up no problem, however a few things are happening that i don’t understand, firstly when i boot up the machine, in the bios my cpu voltage is all the way up to 1.45v doing nothing at 50c which to me is quite concerning but i figured it would go down in windows after installing drivers ect but unfortunately i can never get into windows because my system reboots with no bsod or anything. my ram and all hardware has been thoroughly tested and passed no problem but this is where it gets interesting. I have a silverstone 850w PSU which is brand new and just to be sure i also tested with an antec HGC 850w to rule out psu issues. in the bios if i set the voltage of the cpu to 1.3v and have the frequency set at 3.6ghz it will boot perfectly fine and run all day no issues, but as soon as i turn on ryzen master or have the bios set to auto, the voltage is way to high and i cant get to windows due to it rebooting over and over. the fact that it works at forced stock settings seems odd and i may be missing out on turbo boost ect due to have it run at a fixed frequency. i thought it could be an old bios so i updated to v2.30 but no luck, the same issue persists, does anybody have a way i can fix this or have the same issue, its driving me crazy

First, the voltage and temps are completely normal.

Are you running with xmp on?

Will it boot into windows on just 2 sticks?

What voltage is the board selecting for your ram?


Beeing in BIOS is a situation that requires maximum stability, so your CPU will get fed full voltage at medium clock speeds. This is fine!

Just as @Adubs suspects, could be memory (XMP) related.

Seems like a memory issue, have you tried loosening the timings or just putting them to stock speed?

The stock vcore seems pretty normal compared to my 3700x, as said above, it pumps a lot of vcore in bios to stay stable no matter what!

Does Ryzen master crash with some of the settings you have in BIOS?

First off thank you for the replies, it is more than what i got from the AMD forums. I have tried booting with just 2 sticks and even a single, but it still does the same. the memory voltage is at 1.2 with or without XMP enabled. I do not have any different ram to try as i only own 4 sticks of 16GB of corsair ram. the system boots fine and goes into windows no problem if i fix the frequency to 3.6ghz and run the cpu at 1.2v. I have spent hours trying different settings ect even disabling turbo and PBO on auto but still no luck, it seems fixing the voltage and clock speed is the only way. At this point im at a loss on what to do. If I run ryzen master it will go into it and show my settings, but as soon as i pick game mode ect and apply it, the system reboots without error or bsod

Just an update, i am unable to run the cpu even at [email protected] as soon as i run cinebench R20 it will reboot

You can run the RAM at 1.35v safely. I only saw one 2400 dual rank Corsair stick on the qvl. No idea if it’s what you bought. The fact that it doesn’t boot at 2133 is concerning.

1.2v on the cpu is pretty low so I’m not surprised it has issues there. Try turning off pbo completely and set fclk to 1200. Leave the rest on auto.

1 Like

If he sets a fixed Vcore voltage, then PBO will be pretty much useless.
Especially if you don’t do anything with LLC.
I’m not sure if his particular issue is really memory related.
I do have my doubts on that personally.
He could try setting the Soc voltage from 0.9V to 1.2V and see if that works.
If the Soc voltage is also set to auto it often defaults to 0.9V.
Which can become a stability issue with faster memory modules.
Upping the Soc voltage could help some here.
However keep in mind that the Soc voltage should never been set higher then 1.2V.

Which is why I said to leave the rest on auto. It’s not clear if his board is picking silly defaults on auto or if he has an actual CPU issue.


Well yeah it’s an Asrock board which doesn’t have the most refined bios.
So yeah chances are there indeed.

1 Like

I’m really just taking shots in the dark to see what sticks. I’ve never seen a zen2 cpu do this in particular. I know that some boards had some significant ram issues on the current bios but being that hes only on a 2400 kit, I wouldnt expect that to be an issue for this board.

If it were me, I would just start throwing parts at it until it worked and RMA the rest.

1 Like

my memory does boot at 2133 but unless i fix the voltage and frequency on the cpu it will not get to windows

Interesting. Did you try feeding it 1.35v at 2400? You’ll want to plug in the timings yourself probably.

not yet but i did notice one thing, if i restore stock settings in ryzen master, i notice that the ppt goes back to 88w. I’m confused as to why it shows 1000w when i set the voltage and frequency, after i restore defults in ryzen master it boosts to 4.2ghz for a few seconds then reboots

Because you’re bypassing PBO with that. Those values are the basis of how the CPU boosts. When you set values yourself such as frequency and vcore you effectively take them out of the equation.

What temps is it reading when you boost to 4.2 in those few seconds?

between 50-60c

1 Like

Just as a sanity check, whats the exact model of your PSU? or do you know if its gold/platinum/etc…

SilverStone Strider ST85F-GS V2 Gold 850W Power Supply1547094551-SST-ST85F-GS-V2-th

1 Like

also has 70 amps on the 12v rail, i have tested with another psu and it still does the same

1 Like

How long ago did you get everything in for the build?