Return to Level1Techs.com

Ryzen 2700x, CH7, 32gb 3200Mhz Trident rgb RAM stuck at 2133Mhz


#1

Posting here after having done a lot of searching and reading and I think I’m SOL.

I just constructed at Ryzen 2700x system on the Asus Crosshair Hero 7 wifi, with 32gb of 3200Mhz CL16 G.Skill Trident RGB RAM. (4x8Gb sticks)

Unfortunately, the ram only registers as 2133 Mhz. (I tried overclocking it in with Asus’s EZ feature and now it registers as 2196 Mhz…

Most of the results I find when trying to research this issue say that there is a difference between the CL14 version of this ram (Samsung-b) and the CL16 version of this ram (Hynix). The samsung-b version seems to be working fine, but I can find only 1 reddit comment about how you’ll have a bad time with Hynix.

Here are my current RAM settings here and here

I am running the latest BIOS 0804.

Has anyone else come across this? Any suggestions?

Much appreciated


#2

Unfortunately, the ram only registers as 2133 Mhz. (I tried overclocking it in with Asus’s EZ feature and now it registers as 2196 Mhz…

From your post, it’s not clear to me what have you done so far in terms of setting your RAM frequency and timings in the BIOS. All memory kits will run at 2133MHz out of the box unless explicitly told otherwise, and this EZ thing you mention sounds like auto-OC software rather than RAM settings (which technically are overclocking, but typically show under XMP or D.O.C.P.).

What and how have you tried?


#3

I had this

Turned out to be a bent pin that wasnt even in the hole…

Crazy thing is it would boot and run perfectly fine, only problem was the ram speed.


#4

I was unaware that all memory defaults to 2133, thanks. That being said, I’ve tried manually setting the ram frequency in the bios to 3200. Honestly I’ve just been randomly trying different combinations of things in the extreme tweakers section of the bios to see what different settings would do. I’ve also tried just simply setting the memory frequency to 3200 and the machine fails to boot. I can start making a list, changing only one thing at a time, but I’m honestly not sure what I should be focused on.


#5

You may not be able to get all sticks to 3200 with four of them. I’m running 4x8 Hynix at 3000 but anything higher is either unstable or doesn’t boot.

I’d suggest using DOCP and moving up the list starting at 2666 and see how far it goes before boot failure.


#6

A suggestion that may help you find out more information about your ram is a nice little software called Thaiphoon Burner, it may give you some insight on how far you can push the ram.
Open the software and press read and you should get something like this:


#7

I started stepping up from 2133 and I can get to 2400, but then 2666 and above crashes.


#8

@Novasty thanks for the suggestion. I checked it out and got this.


#9

Have you tried 1.35 volts yet?


#10

Yeah, I’ve been at 1.35v the whole time I think.


#11

I think I’m just going to try and send the RAM back and purchase the other samsung-b CL14 version. I’m just really frustrated that there’s this “gotcha” of 2 different types of RAM, with almost the identical names, though one is made by Hynix and one by Samsung and one works and the other doesn’t. It’s just shitty.


#12

Default for DDR4 is 1.2v but if you used DOCP it should set it to 1.35v.


#13

If you’re a Windows user, there’s a really good tool called the Ryzen DRAM Calculator, which helps immensely. It looks like you’ve already used Typhoon Burner, so I guess you are in Windows, and that tool is step one … so you’re almost half way there.

Best of luck!