Return to Level1Techs.com

Ryzen 2400g random freezing on Lubuntu 18.10

helpdesk

#1

Not entirely sure what the issue is but, despite having installed amd mesa drivers, and updating system software to their latest version. I get hit with system freeze ups at random intervals. Any ideas as to what may be causing this issue.

addendum: I believe that my problem may have something to do with asrocks built in wireless chipset.


#2

Could you provide a full list of hardware in that system?


#3

specs:
ryzen 5 2400g
asrock ab350 itx/ac
-intel dual band wifi-ac 3168ngw

8GB ddr4 (2133?)
256GB ssd/3TB hdd
650W psu


#4

I have that board in two machines running manjaro. While I am not using the wifi, I have doubts about it being the problem.

I’m not home at the moment so I can’t look into the UEFI myself. I would try to find anything that smells like “energy saving”, “cool and quite” … and disable all of that.

Also what memory exactly? Brand, SKU, number of dimms?


#5

1 dimm of corsair 2133MHz: I’m loading up the bios to check the model number.

edit: 3000MHz not 2133


#6

update: cool n quiet disabled. looking through rest of bios to see what I can dig up.


#7

That might be the issue. You need the actual SKU name and look that up in the compatibility list.

General advice for APUs: you want fast high quality memory because it isn’t just system memory but also VRAM at the same time. You also want it to run in dual channel mode … which yours does not since it is only one stick.


#8

let me take a look


#9

corsair vengeance lpx:
model #: cmk16gx4m2b3000c15r
ddr4 3000MHz cas15
edit: the stick was a pull from a system I had made for my brother.
the back label also makes explicit mention of “i5/i7” which might be a red flag


#10

No, that is just marketing fluff.

I am guessing the r at the end of the product name is just for the color. If so ASRock has it listed as supported up to 2933MHz. So, just clock it down a little and see if that helps.

Also a UEFI update might not be a bad thing.

Here is the support page for your board:


#11

gotcha

also, should I mess with the cas when under clocking


#12

I’d go with no on that one.

But you could nail voltage on the memory to 1.35. … one less variable, just for lolz


#13

How often are you having issues? I’m running the same OS and APU on an ASRock B450M Pro4 and while not rock solid, it has been much more stable than anything else I have tried. I have the Oibaf PPA installed and I’ve just started messing around with my UEFI settings. It has rebooted on me 3 times in the 4 weeks that I’ve been running the new Lubuntu, and I’m not sure if anything I did in UEFI/BIOS has had any impact given how intermittent it is.


#14

@KleerKut frequently with this system linux or not, which resulted in me waiting 6 months to get back to working on it

edit: it usually accures with about 15min-1.5hr after booting


#15

@noenken I changed the dram timing from auto to xmp 2933, voltage set from 1.2 to 1.35. I think this may have been the issue. I’m going to begin testing


#16

btw: thanks for the help, I would have been able to figure this out without you m8


#17

update: the system froze again, although it lasted a lot longer than before.


#18

Damn. I have a laptop with similar problems and I have to do something about that machine shortly or sell it. But maybe try some of the stuff that was suggested to me.


#19

solved the issue! I switched to manjaro, haven’t had a single freeze up. I think it had something to do with the drivers


#20

@noenken I am almost definite at this point that this freezing issue lies with the wifi. it looks like after I flashed the bios months ago, asrock came out with an update to deal with the intel wireless, amd compatibility . https://www.asrock.com/mb/AMD/Fatal1ty%20AB350%20Gaming-ITXac/index.asp#BIOS