RX 5700XT crashes when gaming

I have a Sapphire Nitro+ 5700XT on Linux and I get these really weird crashes in games. I’m hoping the level1 community can help me really dig in the weeds to figure out what’s going on because short of buying a new graphics card I’m not sure what to do at this point. This is a bug I opened 2 years ago on the issue GPU hang when playing most games (#1047) · Issues · drm / amd

Back in march of 2020 the issue went completely dormant and my card worked flawlessly for 2 years for it to all of a sudden resurface earlier this year. No matter what versions of software I try I can’t make it go away. My current system specs are below:

OS: Debian sid
Mesa: 22.0.2
Linux: 5.17.5
AMD firmware: 20210818
Motherboard: Gigabyte GA-AX370-Gaming K7
CPU: Ryzen 7 1800X
GPU: Sapphire Nitro+ RX 5700 XT
PSU: Corsair HX1000i

I have checked GPU temperatures while gaming but nothing looks out of the ordinary. I’ve attached a syslog from during the crash, when the crash happens all of my monitors go black however the rest of my system continues to function normally, I can even login with ssh.
crash.txt (339.6 KB)

I have tried reseating my card, as well as rolling back to older kernel versions, compiling different versions of mesa from source, etc. It happens with both OpenGL and Vulkan games and I can’t seem to find a commonality other than it only happens when gaming, presumably due to the high load. I’m really hoping someone here has the skill set to assist me as so far everything I’ve tried has failed.