Return to Level1Techs.com

Rx 5700 and GTX 1080 same system nightmare

gpu
#1

Hi everyone, new here. I wanted to ask if anyone has any experience running both an rx 5700 series card along side a GTX 10 series card? I have been trying to do so for some time now and it seems that I cannot get the display manager to open properly when both cards are installed. If I pick one or the other it seems to be OK, granted never fully graphically complete (low res, etc), unless I go strictly with the GTX 1080. I was originally trying to utilize Nitrux OS and demo their vmetal application, however I changed that due to the social media manager over there indicating they do not have a working AMD driver for the RX 5700 series cards yet. I switched over to Pop_OS as I know it includes at least a much closer semblence of ubuntu repositories.

I am continually stuck at:
Starting Gnome Display Manager
(OK) Started Gnome Display Manager

Then nothing, just the flashing cursor. I can switch to a different TTY and log in at least, and I did do the initial post install setup with just the GTX 1080 connected. I also took that time to update the nvidia driver from the pop shop, and downloaded the AMD official ubuntu driver and installed that. Then reinstalled the RX card and rebooted, now I am stuck as explained above. Maybe someone can point me in the right direction?

0 Likes

#2

Yeah running both isn’t a thing. At least, running both in host. It seems you are trying to run both on the hosh, and not putting one to a vm, which isn’t even close to being a thing. You can’t even do that on windows or bsd.

I would look at getting a second 1080 or 5700 if you desire more gpu horsepower as running both is not currently possible.

Thanks to nvidia, it probably never will be.

0 Likes

#3

Hmm, I must have explained that poorly. I do in fact want to use the 1080 in a vm, that’s what vMetal is designed to streamline.

Additionally, I did in fact get both working in windows before I wiped all my drives. To be fair I only had the displays running on one, but windows saw and was able to at least compute with both at the same time (Crypto mining as a test). Given that I want to use the 1080 purely in a VM I would be happy if I could disable/delay it somehow but I don’t see that as an option on my BIOS anywhere. I am currently using an Asrock X370 Gaming Fatal1ty board.

0 Likes

#4

You disable it on your kernel command line, or elsewhere depending on distro. That’s vfio’s job. Also blacklist all the associated kernel modules (drivers.)

BTW welcome to the forum!

1 Like

#5

Or simply unbind, override and bind to vfio-pci, this works well with a 1080Ti. This is the modern recommended method. ie:

# load the vfio-pci module
modprobe vfio-pci

# stop your window manager if it's using the GPU already
systemctl stop lightdm

# unbind it from the virtual console (this does all consoles, you might want to target the specific device for the 1080Ti)
for F in /sys/class/vtconsole/vtcon*; do
  echo 0 > $F/bind
done

# unbind the GPU from whatever driver is using it currently
echo "0000:24:00.0" > /sys/bus/pci/devices/0000:24:00.0/driver/unbind
echo "0000:24:00.1" > /sys/bus/pci/devices/0000:24:00.1/driver/unbind

# override the default driver so the kernel selects vfio-pci instead
echo "vfio-pci" > /sys/bus/pci/devices/0000:24:00.0/driver_override
echo "vfio-pci" > /sys/bus/pci/devices/0000:24:00.1/driver_override

# trigger the kernel to re-probe the device drivers for these two devices
echo 0000:24:00.0 > /sys/bus/pci/drivers_probe
echo 0000:24:00.1 > /sys/bus/pci/drivers_probe
2 Likes

#6

Thank you both, I will check into that further! I’m still quite the n00b!

1 Like