RX 5600XT GPU passthrough issue: works but unidentified card

Hi guys, I just posted on reddit regarding my problem, so I decided to expand here to see if anyone can help me (/r/VFIO/comments/iou3uq/help_rx_5600xt_gpu_passthrough_issue_works_but/ @ reddit).

I have this setup where my RX 5600 XT is kinda working on my passthrough, the issue here is that the guest does not recognize the card fully, and it keeps on a low config mode (800x600) and I can’t install the drivers for it. The RX 480 works normally BTW.

I’ve tried all possible options on my grub kernel cmdline, tried switching pci-e, iommu groups, downgraded my bios to a previous AGESA, applied the Navi reset patch to my 5.6.9 kernel (although a haven’t seen it being used on dmesg)… but still not 100%…

This is the lspci output on my linux guest for debug:

03:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Device [1002:731f] (rev ca) (prog-if 00 [VGA controller])
Subsystem: Gigabyte Technology Co., Ltd Device [1458:231d]
Flags: bus master, fast devsel, latency 0, IRQ 32
Memory at e0000000 (64-bit, prefetchable) [size=256M]
Memory at f0000000 (64-bit, prefetchable) [size=2M]
I/O ports at f000 [size=256]

Weirdly enough the card’s model [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] (from the host) gets replaced by the word Device on the guest.

No errors dmesg are jumping out … so… out of options here, any help is much appreciated.


can you please post the full XML (or qemu script) for the guest?