RX 480 drivers with linux

I am having a hard time installing drivers for my RX 480 on Ubuntu 16.04. The graphical drivers program doesn't even detect I have a graphics card. My display "works", but it doesn't run at the full resolution. How do I install drivers for it.

can you dump the output of lsub ?

I think you also need to have the 4.8 kernel which 16.04 doesn’t have. You might have to look into upgrading to 16.10 or into arch or fedora. You can also figure out what kernel you have by typing in uname -a.

It says that there is no command found.

well that was the weird thing about ubuntu 16.04 and the rx480
the download from amd's website "just worked"

is it standard ubuntu 16.04 and not the gnome or kde version??

It is the Gnome version.

That is odd they must have created their own custom kernel to get that to work.

I installed 16.10 and it worked out of the gate. 16.04 was failing on me as well. It was Gnome.

I tried the download from the amd website. It worked this time. I want to thank you guys for your time.


You'll find in the future that they will just work out of the box on newer distributions (16.10 and going forward, Fedora, SUSE, etc). 16.04 will require the PRO drivers which is what you downloaded.

1 Like

Ok thank you

I got somewhat the same problem installing the drivers, they basically just crashed my linux desktop, so i'm using window$ atm.
anytime i start ubuntu all i get is flickering graphics after the login procedure, and i basically have to use the ctrl+alt+f2 and sudo reboot they system.

This whole Ubuntu being out of date and slow to update vs cutting edge MESA stack thing is really causing newcomers to Linux to believe all the need to spend hours in the terminal and nothing ever works fallacy. Another 6 months and that should settle down but its a bad time for the casual Linux user wanting a gaming platform with all this change right now.

People should just forget about Ubuntu and move to something fresher where they can learn how to manage a more progressive system.. anything would do, Fedora, Suse, Arch, Manjaro, Solus etc.. Just not Mint or Ubuntu.. at least not if you want aggressive updates for the latest GPU performance.

MESA has nothing todo with the problems, MESA is naught more than an mediator between the AMD drivers, and the Kernel, the fault lies 99,9999% at AMD and lazy driver development, infact MESA was originally invented as a way for non 3d cards to use the CPU as an accelerator for the desktop.
As for any linux desktop i wholeheartedly agree with your fancy quote, Linux is not a desktop environment(It buries microsoft, android and what not as a console/server though), but the alternative is M$ which means telemetry so its abit of a no brainer which i prefer, and which environment i'm forced to use due to capitalistic whoracy(e.g M$).

Let me clarify. I was merely pointing out that the speed of GPU driver development (fast) vs running a slower updating distro like Ubuntu, which unfortunately is the main Distro newcomers try out and they are failing to install the correct drivers as a result. Obviously this will change soon but i wonder how upto date the driver will be vs Arch given the rate of kernal/driver patches that happen on opensource.

Ive tried Antergos 3 time or is it 4 times. It worked like a charm for a month sometimes more then fails horribly.

Since I cant actually fix it its Ubuntu

I have had the same issue previously, i had a new install and within the first update it broke. Second try the same. then i waited 3 months before distro hopping and trying again .. update = broke. Gave up on Antergos a long time ago. Had much more success with Manjaro, up until recently when the installer would not work in advanced mode :/

Still, Manjaro is a much better adaptation of Arch with a 2 week staging window for update testing over Arch.

Im somewhat firmly in the Fedora camp. Fedora has yet to fail me. Even doing an Upgrade from 24 to 25.

1 Like

Never tried it but i am tempted.

For Ubuntu 16.10 you will have the drivers by defaul.

For your current problem, the instalation should be quite simple.

Just download the AMDPro drivers

Unzip the downloaded file, and after that you will have a file named "driver-install". Just execute that and you should be all set.