Return to Level1Techs.com

Rsync Fails since update to 11.3

I have 2 rsync jobs that go to another set of drives that aren’t attached to shares. The first rsync job that makes a backup copy of all my media runs nightly hasn’t had an issue. But the second rsync job that makes a copy of all my documents and programs that runs weekly keeps failing. This has been happening ever since i updated from 11.2 to 11.3. I am running the 11.3-U2.1. I tried deleting the “home” rsync job and recreating it and there is no difference.

Please help

Please post the script as we cannot extract anything useable without it.

1 Like

rsync reporting in FreeNAS was broken before this so it could have been failing the whole time.

Also, you should explicitly state that you’re using FreeNAS (I assume) in your original post. It is only apparent based on the version numbers.

In my experience, the easiest way forward is to set a log file in your rsync auxiliary parameters and search for errors there. Unfortunately, FreeNAS rsync reporting is basically nonexistent beyond success/failure.

I finally had time to dig into it more last night. The whole issue was because i created a Dataset in my Backup array for Plex to back up my stuff so i could recreate the plug in because i was having some issues with it. Because it was inside of one of the backup datasets Rsync couldn’t get past that were was a “folder” in that dataset that wasn’t in the main one. Once i deleted that dataset everything worked perfectly again.

I’m sorry i posted this question before i dug into it more like i should have.

2 Likes

Its good you did, though, cuz I bet this will happen to other ppl and they can see how to fix it now. :slight_smile:

2 Likes