ROG Impact BIOS flashback issue

I got an ROG Impact. I've flashed the BIOS twice before. It's on the 0903 revision, and I'm trying to update it to 1002. I've done it twice before so I know what a successful flash takes, and I've followed the steps a few times very closely, but it just doesn't want to work this time. The light that signifies the start of the BIOS flashing doesn't even turn on. There's no solid light.


I have

-Formatted USB to FAT32, even though it was in FAT32, just in case.

-Renaimed file to M6I.CAP. Though the first time I did it, I have vague recollection of leaving the .CAP out when I did this. Probably just a faulty memory.

-Used the bottom USB 2.0 port-Held the ROG connect button for a good 20 seconds a couple times.

-Tried 2 USB flash drives, one that I used the last time I did this.


And the USB is detected when in that same USB 2.0 port when I'm in windows.

Something else to note, my AISuite 3 and EZupdate utility thing isn't connecting to any servers (I've never had it update through this ezupdate utility because it never works, I suppose I should just get rid of it). It tells me everything is up to date, and when checking for BIOS updates it doesn't stop.

Thanks for any help, yo.


I found a thing.

When I flip the powersupply off, the computer doesn't turn on, but the C/ CMOS button glows till the power is drained. I tried turning it on again, and it glowed for a little longer, so I did it again and held the ROG connect button, and it started flashing properly. But then the computer powered completely off and it stopped.

This leads me to believe that there's a specific power state that I turned off in the CMOS or something like that that's preventing those buttons to glow all the time. That seems familiar, actually. I remember it used to bug me when I was trying to sleep. I'll try some stuff out and then get back to this I guess. If I can't do it through the BIOS, I'll clear the CMOS. Clearing CMOS will be a bit of of a pain in the prolapsed anus because of my RAID 0. I dunno if RAID 0 configs are supposed to fail when you clear the CMOS; it seems logical because the settings in the bios would change and all that fun stuff, but it happened the last time and that sucked because I didn't know that happened and I had no backup. This time I do. Still annoying.

As I see the thread now, nobody has responded, so I'm just using this as a log for future reference just in case I screw up again.  

Yeah, it was a C-state issue.