Ripping my hair out trying to disable Nouveau and use Nvidia 384.111 in a Ubuntu Passthrough VM

Bare metal, I know exactly how to get Nouveau disabled and get the Nvidia Proprietary drivers working on Ubuntu 16.04 LTS… It’s a goddamn nightmare in a VM. The video doesn’t show up when Nouveau is disabled, DKMS doesn’t build on newer kernels… And I’m having so much trouble getting it to work with KDE…

Passing through a GTX 1080 with Nouveau is good, but passing through with the actual drivers would be better… but I cannot for the life of me get it to work…

I’ve done everything and I’ve always ended up that if Nouveau is disabled, no picture comes up on the card…

Is this hard evidence that there’s also a Code 43 error in the Linux drivers? JESUS CHRIST. Keep in mind, no picture shows up after disabling Nouveau anyways.

Edit: Seems like the NVIDIA persistence daemon is failing.

1 Like

Ripping my hair is ususally a sacrifice to the kernel Gods. Don’t be worried, you just need a minute to unplug and come back. You are almost there


Problem is I have no picture if I disable Nouveau, but I can’t install the drivers with Nouveau enabled. I installed the drivers over spice, but I’m not getting ANY PICTURE when the initrd has nouveau blacklisted.

Edit: JESUS CHRIST. Nouveau doesn’t even work anymore.

Edit 2: I’m reading that I need a ROM dump in order to use the card in a Ubuntu VM… Not sure if this is true cause I didn’t need a ROM dump to use Windows.

Couldn’t you just set up the vm before you give it the GPU, that way you can enable sshd and get in remotely?

It WAS working with Nouveau, now I’m struggling to even get it working with Nouveau. My goal is to get it working with the proprietary drivers.

From the way it was worded, you made it sound like you couldn’t work on the machine.

At least that’s how I read it.

NOT THE HOST. I’m trying to make a Ubuntu Guest VM in Fedora.

Just tried the ROM image, and as usual, I get the 100% failure because the ROM file prevents the GPU from even initializing and it drops straight to text console.

Right. Well, best of luck to you.

According to this thread, Nvidia Code 43 ALSO EXISTS for their Linux drivers:


Edit: OMG, after doing a fresh installation, passthrough doesn’t even work on the card anymore with Nouveau.

Edit 2: FUCK IT. Giving up. The Live ISO works with Nouveau but as soon as I go to boot, it just NEVER initializes.


Ubuntu only works with Nouveau with the Q35 chipset in FC26… but then Q35 doesn’t work with Windows VMs in FC27…

Quick test, does Q35 still work with Ubuntu in FC27?

Not sure, but sounds like you need to use something other than Ubuntu LTS.

I’m experimenting here. However this has gone so terribly wrong that nothing works anymore.

Ahh, I sympathize.

Well, it worked for one boot. For subsequent boots, SDDM fails and Nouveau completely drops the card…

Gonna try Kubuntu 17.10.1 now.

Edit: Okay, 17.10.1 works with the FX chipset with the proprietary drivers with the same Code 43 patch to lie to the guest that it isn’t in a VM. Gonna try Q35.

Edit 2: FC26 Q35 has cursor lag in Kubuntu 17.10.1 while running Nouveau… Huh. It does successfully install the proprietary drivers too, but it looks like the FX chipset wins here. I’ll be doing FC27 testing in the morning. Don’t do a Ubuntu 16.04 VM for GPU passthrough, do a 17.10.1 VM if you have a GTX 1080.

Woke up with a fresh mind, still no dice on Kubuntu 16.04 on both Q35 and FX on FC26 with kvm=off. The card is just too new to work with that old of a ISO.

Will be moving onto FC27 testing momentarily.

Is your Nvidia GPU seated in the primary slot of your MOBO?
“Sometimes” it happens that’s where the OS looks first for it’s GPU.
Id slap your run of the mill 30 bucks GPU in PCI-e slot 1 then your GPU to pass through in the 2+ slot.
I had a similar problem some roughly a year ago(might be two), and for the love of me that nouveau killed me.
It was either emergency consoles on boot, or the Nvidia GPU.
in the end i finally got the GPU on the CPU die to pass through, but that seemed abit counter productive, and i abandoned the project.

I tried the same project some time later where i ran into regardless of how i disabled the GPU and so on, it insisted on, at a BIOS level to use the primary slot for output.
If i disabled the primary GPU in the OS, the secondary GPU simply rendered, and outputted on the primary e.g. slots 1 and 2+.

This is not an issue with the boot order on the host or the GPU order on the host, this is purely a QEMU/KVM problem with incompatibility. FC26 QEMU doesn’t work at all with the GTX 1080 on Kubuntu 16.04. FC26 QEMU “somewhat works” with the Q35 chipset on Kubuntu 17.10.1, but FC26 QEMU DEFINITELY works with the FX chipset on Kubuntu 17.10.1

Initial testing on FC27 shows Kubuntu 16.04 boots and nouveau properly activates on the Q35 chipset, but the Realtek Ethernet controller is unrecognised after booting into the finished installation, making it useless. FX chipset doesn’t even work at all with 16.04.

Q35 doesn’t work at all for 17.10.1, but FX chipset does in FC27 for 17.10.1.

Okay, after extensive testing, it looks like the only version of Ubuntu that will work in the most current version of QEMU with a GTX 1080 and the kvm=off command to enable the proprietary Nvidia drivers with the FX chipset in both FC26 and FC27 is 17.10.1…

Though the screen locker and logoff/shutdown is broken in 17.10.1 in Kubuntu specifically immediately after installing the proprietary drivers… A little annoying.


My Threadripper system down the line will be all AMD. Vega 32 for the Host, and Vega 56 for the VM.