Repairing a PlayStation 3

So I inherited a box of rejected electronic devices from my brother. Some or all of it was from his house mate who moved out and left stuff.

Among other things, there was a PlayStation 3 in the box. It is the more recent "ultra slim" model. It was mostly torn down, and there were two power supplies with it.

I assumed that the previous owner deduced that it had a bad power supply. I tried both, and the PlayStation will not power on with either insalled.

Here is the exact order of what happens:

Plug in power
Front light turns red (standby)
Press power button
Front light switches from red to green, fan spins up
Attempts to power on for approximately two seconds, but shuts down
Light on front completely off, no color at all
Press power button, light turns red for standby
Press power button again, light turns green, fan spins
Repeat ad nauseum

I tried both power supplies, but I am not sure if they are even good.

I took the heat sink off and reapplied the thermal paste. I also checked the button cell battery. Neither did anything.

What should I do?

I am a PC gamer. Never really had a console. I just want to try out a PlayStation and some of the PS exclusive games.

But if it's dead, well then it's dead. Just hate to scrap something nice like this.

edit: I tried getting into recovery mode using this link, but it does not work.

Could be a psu issue. I had a similar problem with my brother's 360, opened up the box on the cord to see what the problem was, lo and behold some burn marks on the pcb. You can usually find the psu for cheap on ebay/amazon/craigslist if that's the case.

Now we can't be sure that it's a psu issue... but that's a good place to start.

i don't know how much it's worth even the time you'd have to put in fixing that i mean i wouldn't. Have fun though! it's a joy playing last gen , i know i enjoy my ps2 games even now ( on pc )

@ThatBootsGuy It has an internal power supply, unlike a 360. Just uses a simple two prong AC line cord that plugs in the back of the console. The internal power supplies go for $20 on ebay. But like I said, I think that's what the previous owner tried to do, as there are two of them already. I just don't really know why there are two of them, or if one is good. I would hate to drop 20 bucks on it to find it really isn't the power supply. Then I'd probably have two good ones and a bad one.

@Bane Yeah, I just like to fix stuff. Or try to. I'd like to play The Last of Us and a couple other PS exclusive titles.

There was a black Xbox 360 in the box, with the ends taken off. So I have no idea what's wrong with that. Don't have a power supply for that at all.

In that case... it's probably something else internal that's causing a problem... check all the connections to make sure they're snug, etc.

Yeah, I tried powering it on without the optical drive and hard drive installed and it still didn't work. The only other thing I can disconnect are the two cables for the WIFI and the Bluetooth, but I don't think that will do anything. I will probably have to take the heatsink off and take a real good look at the motherboard for problems.

Thats a faulty power supply. Likely just bad surface mount components. Easy fix but the stuff inside the components could have corroded the mobo by now.


what @FaunCB said, but PS3 are cheap to buy now. Lot of PS4 console freaks selling them for low price. Unless it's a PHAT edition (shiny black and big and max 80GB, they can run different Unix OS).

But PS3 and all consoles (these days) are just annoying PC's made difficult. Fixing them is made difficult because you're not allowed to......

The only difference in the original PS3's to the slims is there are 2 UART's that are easily accessible to install the E3 chip to for CFW. I have put my SSD in my PS3, worked, 1TB HDD, worked. The power supplies just had the ability to fail.

However on the original release PS3's they actually crammed a PS2 in there. On the second rendition, the one I have, they added an Emotion Engine CPU and other hardware to the board to "emulate" the PS2, and on the third rendition PS2 system emulation was completely software.

Fun fact's.

1 Like

yeah tho its not a fun fact that they insert a PS2 in it and then remove it.... XD

Well what they wanted to do was run it all on the PPC system, which was more than possible, but it would drive the prices up and likely end up in failing game wrappers. The costs would have been too high if they jumped right on emulation so they just stuffed one in there.

Fixing electronics is not that hard.

So, yeah, I just fixed it. Probably.

I got a cheap (but surprisingly nice) hot air rework station and I reflowed the CPU and GPU.

It took three tries, though. First time I got it back together, powered it up, and got it to boot. I was elated. Then it kept shutting down after a couple minutes. But hey, it had booted and I had video. So I tore it down again and reflowed the CPU and GPU. About half way through I realized I had forgotten to reinsert the CMOS battery. So I finished the reflow, reinserted the battery, put it back together, and had the same original problem. I felt terrible, and I almost gave up. But I decided to try one last time. This time I cranked the heat up on the rework station and ran it on each chip for a bit more time. While it was cooling I could hear the board clicking, and I though I had gone too far.

But I put it back together and it booted straight to the main menu. I don't have a controller, but it worked fine with a keyboard. Then I did a full settings reset, and now it won't let me get past the "connect a controller" welcome screen.

But, hey, it's been sitting there running for about an hour. We'll see if it's still running in the morning.

edit: and I also went through a metric ass load of MX-4 thermal compound with all the taking apart and putting together cycles I did. Oh well. And I did actually get a new power supply. It obviously didn't fix it, but I decided to use it anyway.


Thread has been revived 2 years after the last post. This exceeds the 3 months grace period. If the original poster of the thread wishes for this thread to be unlocked they can message me, a leader, a moderator, or an admin. This thread is locked.