Regular frame drops in all games

hey there,

 

A few months ago I built my very first pc gaming rig and I am quite proud of it, but it has some downsides for me. but before I get into the issue here are the specs:

 

Mobo - asrock 970 pro 3 r2.0

GPU - Sapphire 7850 OC edition

RAM - Corsair Vengeance ddr3 8gb 2x 4 

CPU - AMD black edition 8320 3,5ghz 

CPU Cooler - Thermaltake Spinq 

PSU - corsair CX series modular CX600m

Case - Bitfenix shinobi

Seagate 1tb HDD

OS - Windows 8 pro

AMD Beta driver version 13.11

Now back to the matter at hand, I have been having issues with my build from day one realy. My original HDD turned out to be malfunctioning so I replaced it with a 2nd hand seagate 1tb hdd from a friend. I still sometimes have the issue where in my Disk usage is at a constant 99-100% usage with 0.1mb/s ussage shown on the task manager. I tried swapping sata slots on my motherboard, diffrent cable and I even sent my mobo back for testing to see if my sata controller was malfunctioning, but nothing came out of the test. 

Now I thought the 100% disk usage might be the issue that plagues my rig that causes my frame drops in games. Might I mention that my CPU doesnt go above 70 C in games and my gpu doesnt go above 65c. I also did a health check on my HDD and the results were good, no damaged sectors in my hdd.

For example battlefield 3 and far cry 3 . I play the game quite smooth for about 10 seconds then the frames drop to about 20 or lower for 3-4 seconds and then jump back up to 60 ish, This happens mostly in those 2 games but also in bioshock infinite and alot in rome total war 2. This makes playing shooters almost impossible and quite frustrating. 

If you guys need any more info to be of help to me please do so... Im quite sad that my first rig turned out like this with these issues so any help would be greatly appreciated. 

 

Aron

Go into the BIOS and look at the controller mode for the HDD. Try setting it to AHCI and see if it helps.

go into the bios and disable every power efficiency feature in there. Especially if there is something that slows down the cpu when there is light use also known as a feature that increases speed when there is high demand.

@dan93 I already checked and its on AHCI mode, and @atatax I dont think this mobo has a power saving feature on it :/

 

Anyone else have an idea? I changed my beta driver 13.11 to the regular 13.9 and at first it did seem like an improvement but after about 7-10 min regular playing it started acting up again. Could it be that m mobo is having issues with this cpu? 

Try updating the motherboard drivers. Event viewer should also show you what program is hogging the disk.

The disk usage says 100% but when I check the task manager it shows not even 1mb/s is in use mostly 0.1mb/s O.o

 

Your CPU is getting very hot and it could be throttling (AMD did not specify max temp but it seems to be somewhere between 65 and 70 depending on mobo). I suggest re-seating the heatsink to make sure it's on properly, use a pea sized amount in the middle and make sure it's decent stuff (i.e. not generic white paste).

After I received my mobo back from the supplyer I used Ketonatus to clean it off, Idk the word for it in english its 97% alcohol and I bought it at a pharmacy, someone recommended it to me. Because I couldnt find Isopropyl alcohol 

I also did get some thermalpaste with my thermaltake spinq cpu cooler which is greyish in colour

I had a similar problem with an ASrock 970 Extreme3 and FX-4100 where it would Crash loading certain games and have poor frame rate so i updated the bios which has worked but be wary with this...,

So I found out that with far cry 3, when the game is running smooth my cpu clock says 1.389V on CPU-Z, but when the frame starts to lagg, it shows that the clock is 0.888V , and jumps back to 13XXV and so do the frames... so the throttling is the problem, but I cant seem to find the sulotion in my bios, on my asrock 970 pro3 r2.0... anyone have an idea ?

Set OC mode to manual. 

disable AMD Turbo Core Technology if you have it

disable AMD IO C-State Support

set Multiplier/Voltage Change to manual

 

basically every single thing that gives you the option to be automatic or manual, is a power saving feature that should be set to manual or disabled.

I'm seeing this type of issue pop up more and more. The combination of an FX-83XX 8-core CPU with certain 970 chip set motherboards seems to result in the throttling of the CPU due to inadequate VRM quality/design.

The solution is to upgrade to either the Asus m5a97 (R2.0) or any good quality 990 chip set motherboard. Look for a board with heat sinks on the VRM. 

I tried disabling thermal throttle but it still throttles down to 0.888V

Yeah, I just tried putting my finger on one of the vrm's... and I cant hold it there for more than 3 seconds

Thanks for the help guys, Im prob going to send the mobo back to the online store where I bought it. They said they wanted to check on the board, hopefully Ill be able to get an upgrade, or atleast a board with a decent heatsink on the vrm's or even better a board with a 8 + 2 phase design to relieve some stress off of the vrms

Sorry to necro this shit but did you ever solve your problem? I'm going through something similar now, where disk usage is nonsensical and DX9 games have micro stutter every few seconds. I even got a new motherboard, CPU, RAM, and PSU but I still have the issue.