Return to Level1Techs.com

Recovering a drive lost to StoreMI

I tried StoreMI, and created a non-bootable tiered storage volume with a blank SSD, and a 1TB HDD (just data, not the boot volume) full of stuff. Afterward, I decided I should use it with the other HDD in the system, so I go to remove it, and delete the TDD partition. Now, my 1TB HDD has no partition table, at all. I think maybe I can remake the array the way it was and recover it, so I remove the SSD from the second HDD. Now, all I have is a single-drive tier with the second HDD, with no ability to reattach the SSD to the array, because the single drive is technically a tiered storage volume, but with no caching benefit. I’m afraid to delete the partition on the single drive, because I think it’ll just leave it unpartitioned, like the first one. It also won’t let me do anything else because the max # tier drives allowed is one.

Now, I’m scanning the first drive with TestDisk to try and recover the partition table. It’s going at the speed of government, and I’m tempted to just ditch it and wipe everything.
The good news is most or all of the data is noncritical. This is basically a gaming rig so I can re-download 1.5 TB of games or whatever, but I’d love to not.

What’s a noob to do?
thanks

If TestDisk doesn’t work, or you don’t have the time/patience, you could map the partitions manually. [WARNING: Decent amount of Math involved]

Dumpe2fs is helpful for this. Here’s an older walkthrough that is still pretty relevant:
https://www.tldp.org/HOWTO/Partition/recovering.html

It’s not exact, but pretty close. Let us know if you need help or I misunderstood what you’re asking for.

EDIT: Also, if you need to clarify, could you use labels for your drives? (HDD1/HDDA, SSD1/SSDA, etc) It would make understanding your issue a bit more clear. At the moment, it almost sounds like you have four disks: two SSDs and two HDDs.

1 Like

Sure thing- here’s the layout:

SSD0 - ntfs; windows 10 m.2 boot drive (not using this for storeMI at all)
SSD1 - 256GB unformatted; using this as the storeMI “fast” tier
HDD0 - 1TB ntfs; single partition. there was existing data on this that is now inaccessible
HDD1 - 1TB ntfs; single partition. there is accessible data here now on a “single drive tier”

I created a storeMI disk with SSD1 and HDD0. I thought, “Nah, I should do it with SSD1 and HDD1, instead.” I deleted it through the storeMI config, and made one using SSD1 and HDD1. HDD0 now appears to be unformatted to the OS.

I tried rewriting the HDD0 partition table with testdisk. It couldn’t find the EFI partition, but it did find most of the data partition. Testdisk bugs out near the end of the disk and finds two of the same partition; one of them ends on a later block than the other, but writing the partition table to disk fails. Windows won’t mount it, either way.

Listing files for that partition (on HDD0) in testdisk gives me a “downloads” folder (thanks testdisk, of all the things I could recover, it’s downloads :stuck_out_tongue: ).
I haven’t tried dumpe2fs, yet (i’m on windows atm and cooking up a live usb now).
I may stick a 3-4tb disk in and just dump everything to that and ditch these older 1tb’s. It could be that my spinning rust is failing anyway.

Edit: Ok, I think what happened with the partially missing data is that I walked away during a reboot and came back to see chkdisk attempt a recovery. there is a folder called “found.000” full of unorganized junk called “dir000.chk, dir0001.chk,” and so on.

More good news. Drive HDD1 is mysteriously read-only, now. Swapping several combinations of power and data cables did not help. I picked up a 4TB HDD and I’m dumping everything to that. Sticking to, regrettably, NTFS, for now.

Maybe worth mentioning in all this that HDD0 is about 3-4 years old, HDD1 is probably less than a year old, HDD2 is brand new, SSD0 is maybe 1-2 years old, used sparingly, and SSD1 is less than a year, used very rarely.

Dang, checking the manual, looks like one would have to “disable the acceleration,” remove the SSD, then copy the data off the HDD, then destroy the setup. No flexible way to replace.

Backups seem the key to storemi…

Indeed, the instructions are ambiguous, as the documentation refers to fuzedrive, not storeMI. They should be identical, but the UI isn’t. Anyway, I’m done with it for now. Gonna do a full win10 reinstall and start almost completely over.

1 Like

I’m honestly surprised StoreMI doesn’t offer a way to add and remove drives. You’re really only editing the partition tables when you create the tiered storage initially.

Anyway, you should be able to recover HDD0’s partition table using Linux. I apologize for assuming you had Linux available before, most of the people on this forum do in some capacity.

NTFS usually makes a backup partition table at the end of the disk, so it’s possible that this might have been what threw off TestDisk (or old partitions?).

Dumpe2fs can get complicated. You could try opening the disk with gdisk to see if the backup partition table can be used long enough for you to get the scheme, and then manually fix it accordingly.

Other than those, I’m not sure how much help I can be? :man_shrugging:

all good, no need to apologize. I do have a few boxes/disks with Linux on them around, but

  1. didn’t want to open them up and stick this drive in
  2. I tried booting antergos and couldn’t see shit, even at boot screen, due to graphical issues
  3. Said fuhgetaboutit and stuck to testdisk

Testdisk ended up working enough to list the files, but not restore the partition table. The thing that kept me from salvaging it all was actually the chkdisk nonsense, and I may have had a more severe failure than that, as even after a reinstall on SSD0, the partition manager program built into win10 throws errors no matter what I do to partition HDD0. I’ll eventually format it with a liveusb that does work. Meanwhile, I reinstalled entirely and started over. I am downloading 1tb of games :grimacing: at 75Mbps so wooo
Honestly this rig is just gaming and some light coding and accounting so it wasn’t a big loss.
Thanks for your help @1ncanus and @Trooper_ish
Lesson learned: avoid storeMI unless you are sure you want to dedicate a disk.
Fun fact: before the wipe, TDD0 (HDD1 storeMI single tier virtual disk) wasn’t showing itself as available. HDD1 became RO as mentioned, but TDD0 never came back.

1 Like

Cool beans, glad you are taking it well :smile:

All drives die.
Just try and spread the backup word to all those who have a single disk with everything on, unknowingly rushing towards the day they learn to value backups :scream:

1 Like

As trooperish said, this is the use case for backups that most people ignore. Now that you have your 4TB disk (HDD2), you could run some tests on HDD1 to verify that it’s ok and use it for a backup of your largest gaming/coding files, that way you would only have to download/update some differences if this happened again, not the entire 1TB. Because your backup disk would be smaller, you would need to pick and choose what to backup, but it would still be helpful.

As a note though, I would be cautious of HDD0. It might be ok, but 3-4 years with use as a gaming data drive, it probably has run its course. You could run some tests on it and use it for temp storage for things you don’t care about as much. If it fails any tests though, I would chuck it (don’t forget to wipe it if you ever had anything personal like taxes, bank stuff, pictures, etc).

1 Like

For data recovery purposes I take help from memory card data recovery and got proper solutions. Test Disk and Disk Drill i not good enough. A partition manager is actually beneficial. For that EaseUs wizard provides the best results. I would recommend that. Another good one is Stellar phoenix Data Recovery.

I have been trying to get off StoreMi for the past day now as it is preventing Windows 10 updating. I have run into the issue of a system file being located in an area preventing StoreMi from shrinking the disk. Normally I would just use a Linux tool to perform this but the StoreMi propitiatory format prevents this.

However… I just found a solution. AOMEI Parition Assistant (Free version) is able to resize the partition provided you select to run it in “PreOS Mode” rather then the default WinPE mode.

This is an experimental Windows VM… I think I am going to just RAID the disks instead and give the larger volume to the guest and avoid StoreMi completely.

2 Likes

Hi i am new here hope its ok to aks here
i installed storeMi on my system disk and a ssd
after reboot windows faild to boot.
i reinstalled win 10 64bit
and storrMi to now the system drive and the ssd is gray
and can´t bee used :frowning:
any way for e noob to remove all trace of storemi from my drivs ?
Pleas :slight_smile:

https://gparted.org/livecd.php

Use this and just format it to either a MSDOS (BIOS Boot) or GPT (UEFI Boot) partition table depending on how your installing windows

1 Like

Thanks that worked
no more StoreMi for me.

1 Like

I had the same problem after using StoreMI and gparted also worked for me. I too have learn the same thing, no more StoreMI for me.

1 Like

So i am currently having the same issue, but when trying to use Gparted, i get this series of errors, i believe it is because i am using a 3950x and it doesn’t know what to do with it.