Return to Level1Techs.com

Recent RMA of a Ryzen with segfault bug?


#1

Just wondering if anyone has recently gone through the RMA process for a segfaulting Ryzen CPU and what you received as a replacement.
I have a 1700 UA 1708SUT with the bug and I’ve known about it for a while, but have been holding out on doing the RMA because at this point I’d like to wait until I can hopefully get a 2700 in return (Or at least a much more recently manufactured 1700 that clocks better w/ lower voltage and a better IMC).

I’ve been dabbling with Linux off and on for about a year now, and I’d like to eventually switch to it as a daily driver, but this CPU has been holding me back because it’s extremely unstable under Linux, even after disabling C-States and compling a custom kernel with CONFIG_RCU_NOCB_CPU=y and adding “rcu_nocbs=0-15” to grub. It’s unstable under Windows too but not nearly as much. I can get a week or two of uptime under Windows as opposed to a few hours under Manjaro.


#2

I also have a CPU with the segfault error and the lockup problem. People that I’ve heard that have RMA’d there CPU have gotten a newer manufacture date of the same CPU. ALL Ryzen chips prior to, I think it was, week 25 have the segfault problem. The CPU’s recieved in return still suffered from lockup problem.

Even though I run Gentoo and compile packages daily, the segfault problem doesn’t bother me too much, only on big packages like Mesa. I just have to start the compile over, it eventually finishes.

A work around for the lockup problem was issued in a BIOS update. Look for “Power Supply Idle Control” or something similar. On my Taichi it is in Advanced > AMD CBS > Zen Common Options. Change the setting to “Common current idle” It helps, but doesn’t entirely eliminated the problem for me. You can try other settings, but take it off of Auto.


#3

I’ve tried checking that setting too actually but it was already on that by default.


#4

My 1700 also has the segfault bug and suffered from random hard freezes under Linux when in an idle or near idle state. The segfault issue never bothered me or came up unless I run that script that looks for it (I don’t do heavy compiling though). The system freezes I fixed by upping both my RAM’s and SoC voltage (+0.05v in my case).
Better check if AMD is still doing the RMAs, since it has been a while.


#5

I’ve already done tonnes of voltage tweaking and stability testing though. My CPU is just bad. It never crashes under a sustained load, only idle or low load, and seems to happen often when going from load to idle.

It has a 3-year warranty and I’ve already checked around and people are still getting RMA approval, but there isn’t much information on what they’ve been getting for a replacement recently.


#6

What RAM are you running. Mine is super finicky and only runs 2133MHz despite my RAM being 2400MHz.
An RMA at this point will most likely get you a fairly recent CPU, but you never know.


#7

You really dont have to worry about getting a bad cpu.


#8

@Melcar I’m running this kit and it’s dual-ranked E-die:

Currently running it at 2866 but I have all of the same problems at stock.

@Dje4321 I’m not too worried about getting a bad CPU but I want to hold out for a 2700 if I can. That’s why I’m wondering mfg gate for recent RMAs. If I get frustrated enough with it I’ll just do the RMA and take whatever I get, but I can probably hold out for a couple/few more months.


#9

Hmm… can this be done from a live USB? I mean, it should be, can I just stick the ryzen-test into a folder on the same USB drive? I figure I should probably check…

Or I can start a new thread…


#10

You mean run the kill-ryzen script? AFAIK yeah, you can just run it from a live USB disk.


#11

So it’s been a few weeks…anyone do an RMA recently?


#12

I just RMA my 1700. I will send it next week so I will let you know if I get a 2700X.
But I doubt it.


#13

I believe @MazeFrame had to RMA.


#14

I have not done the RMA personally, but I was involved in the process of RMA-ing two 1700X CPUs, this year, early August.
Both of them were RMAd due to the segfault bug, we got replacement 1700X-s. Both of them are free of the segfault bug, but one of them might be a little bit flaky in other ways, but not 100% sure. (the systems have ECC RAM and one of them was getting some corrected ECC errors in the L3 cache)
The jury is still out on the random freeze issues, that has not yet been tested, and the systems are still not in regular use.


#15

Yes I did.
Sent an 1700X in and got a 1700X in return, but without segfault.


#16

Thanks for the replies. Anyone happen to notice the date code?


#17

They are asking me to pay the courier =(… I thought they will provide me with a courier label, not good.


#18

Try to fight it.

Say that that’s not fair. You just spent all this money on a product that does not meet your expectations and now you have to pay for the label.


#19

I already did that. We will see…


#20

Good luck!