Razer Deathadder Not Working

Hey guys, just recently when I got back form vacation my Razer Mouse wasn't working on my asus m5a99x evo. The ports seem to work because I have tried different mice and usb flash drives and they work. I have tried every usb port in the rear I/O (except usb 3). But when I plug the mouse in the front of my case (Rosewill BlackHawk), it works. I have tried multiple fixes that work for a little bit. I have tried updating bios on the motherboard, that didn't work at all. I uninstalled and reinstalled Razer Syapse, it worked for a little bit, than I would shut down the computer and no luck. I plugged in the mouse in a Lenovo Thinkpad and the mouse worked. Please help me with this.


check if your usb drivers on your mobo are up to date.

Funny I have the same issue.  I'm using an ASRock Z77 Extreme4 and a Fractal Arc Midi R2 case.  When I plug into the rear ports, the mouse lights up but doesn't respond, but when plugged into the front usb ports it works just fine.

Is there even usb drivers? All I see is usb 3.0 drivers. Or will it be under chipset drivers.

The sad story is, my mouse doesn't even light up.

What version of the Deathadder do you people use? I have the originial deathadder but haven't had any issues. Do you always have Razer Synapse open? I never ever turn it on and I don't let it turn on when starting my computer as it changes my DPI the whole time. 

Yes I always have synapse open, and it's the Deathadder 2013. The only thing concerning me its the motherboard problem is that the mouse works on the front usb, and on laptops.

Your rear usb ports sounds like a power to component problem, perchance an intel build?



Am3+ on 990x chipset